0

I had an old mobile phone with Android 8.x Oreo. In it, I was using "SSH/SFTP Server - Terminal" app to access my files on the phone through "WinSCP" in "Windows 10". I used to do that while a VPN connection with "UFO VPN" Android app is active on the mobile phone.

Now, I bought a new mobile phone with Android 11, when I tried to do all the things above, WinSCP refused the connection over the VPN and I can only access the files without the VPN.

I tried to solve the problem by using different SFTP server apps and VPN apps with no success.

Any help will be appreciated, with a notice that I don't want to use a normal connection on my phone.

3
  • Is the VPN identical on both devices? Both old and new devices are "stock" (not rooted)? When talking a bout specific apps please always include the link to the app in app store, app names are localized and thus it can be difficult to understand what app you are referring to.
    – Robert
    Aug 23 '21 at 9:58
  • I have updated the post with apps links. The VPN is only on the mobile phone and windows 10 are connected to the internet normally. In the old mobile phone (Android Oreo) it connected successfully from ssh server on mobile phone with VPN to WinSCP app on Windows 10 with normal connection without any issues. Hope the problem in the new mobile phone can be solved.
    – Jameel Kalwan
    Aug 23 '21 at 17:54
  • Please note that I used this method to access my files inside secure folder in galaxy s21 mobile phone.
    – Jameel Kalwan
    Aug 23 '21 at 17:56
0

It seems that the Android version newer than Oreo prevent VPN and SSH connection at the same time, only one connection can be active.

That is very very frustrated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy