I installed Lineage 18 on a Pixel 2 without issues. I followed the official guide (https://wiki.lineageos.org/devices/walleye/install).

The problem is that there is no Play store after the first boot. I wiped again twice and redid everything without issues. Still no Play store and firstboot is normal.

I tried to wipe, install lineage, firstboot, then boot to recovery to install the gapps.zip, but of course that expectedly created problems (system not booting, sending straight to recovery).

I tried gapps nano and pico, same thing.

I'm out of ideas, any help will be very welcomed. I flashed multiple devices in the past and never stumbled on this issue.

Could that be a a-b slot thing? I doubt adb sideloading lineage and then gapps right after one another would send one to A and the other to B. Maybe MindTheGapps would behave differently?

Thanks in advance for any help.


1 Answer 1


Problem solved!

Boot to TWRP, sideload Lineage, from TWRP reboot to Recovery. Lineage Recovery will load. Sideload the gapps. Reboot to system.

A few things:

  • I did get stressed out about the slot thing, but from TWRP, rebooting to Recovery sends to Lineage Recovery (along with a different slot [sometimes?)], so things get a little counter intuitive.

  • In the past I flashed a Nexus 6P, an S4, an S5 and a Nexus 5. It was never necessary to reboot to recovery between loading Lineage (or Cyanogen back then) and the gapps.

  • The wiki doesn't mention that it is required to reboot to recovery to install the gapps after sideloading Lineage. I would update it to add this detail, along with the fact that you go from TWRP to Lineage Recovery in the process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .