My phone keeps showing both the Samsung logos while booting. It also shows the unlocked boot loader screen. I tried flashing the stock boot.img but it only removes the red text when booting. After some time it show a screen that looks like the stock recovery and shows this text:

Try again Factory data reset View recovery logs

I tried to do the data reset but that did not fix anything


1 Answer 1


assuming you have patched the whole rom AP_[device_model_sw_ver].tar.md5 (not only boot.img) according to install instructions (to avoid discrepancies in several fstabs), start from scratch again.

this time try preserve force encryption in Magisk settings to avoid issues with encryption. after factory reset userdata encryption should work again.

Of course as always don't forget to deactivate VaultKeeper before flashing custom binaries

  • Also I use Debian Linux so is there a a method using Heimdall. I also tried Jodin but it just ask to get the pit file and when I press "yes" it Grey's out the start button.
    – Urmom
    Sep 12, 2021 at 10:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .