Question :-How to unlock view get app info "Move app to SD card" option locked missing in android 5.1.1?

I have two mobiles of same company with different model both having same os android 5.1.1 sharing below screenshot of about phone of both mobiles

Lyf water 7 ls 5004 about phone

lyf water1 7 ls 5004 about phone info screenshot photo

Lyf wind 6 ls 5009 about phone

lyf wind  6  ls 5009 about phone info screenshot

But one of the mobile model Lyf wind 6 ls-5009 (with 8gb internal memory) is showing "Move to SD card" option in setting apps but another mobile model Lyf water 7 ls 5504 (internal memory 16gb) one is missing locked not showing option for same app "move to sd card" may be locked by OEM. Screenshot of same app settings for both mobile option pasted below.

Lyf wind 6 ls 5009 app info (move to sd card option available)

lyf wind 6 ls 5009 app info screenshot image


Lyf water 7 ls 5504 app info (move to sd card missing)

lyf water 7 ls 5504 app info screenshot image


** My queries**

  1. How to unlock view or see the same option "move to sd" in another model lyf water 7 of android 5.1.1 by modifying the settings through any adb shell fastboot or terminal with or without rooting the mobile.

  2. I tried app manager III or app2sd or link2sd apps on unrooted and rooted mobile to do the same but all fails to move the apps. All apps when move to sd option clicked they open take me open same dialogue box window to original settings>app>appinfo option to move apps ( as shown in screenshot above) and there no option of move app to sd

Link2sd when app moved to move to sd it gave following error and link to sd is grayed out and disabled and not working (even on rooted phone)


pkg: /data/app/ com.gmail.heagoo.sdcardmovable-1/ base.apk Failure [INSTALL FAILED INVALID_INSTALL LOC ATION]

link2sd move to sd card error screenshot

Storage screenshot of link2sd of lyf water 7


  1. I tried adb shell pm set-install-location 2 in rooted mobile it's changed succesfully but still apps installed through Google Play Store or apkpure do not installs automatically to external sd card they still installing in internal storage not

  2. I know all apps are not movable as their app mainfest don't allow I had tried to edit apk editor default prefered install location to external still same app without editing the app is moving to sd card in one mobile and no option of moving not showing option in another mobile with same android 5.1.1 same app same kernal version same.company but different models it means there is some setting lock or change how can we modify or unlock that option .

  3. Any more setting I can alter to get the result of moving apps to sd card on my lyf water 7 ls 5504. Any adb shell command. I don't know if its locked in rom or hardware incompatibility then will 3rd party custom rom available in xda may be android 6.03 or android 7.1.1 or android 8,9,10 will allow or have such option and work in the same mobile or not

  4. If there is any hardware or rom uncompatibilty or lock by manufacturer or vendor I am worried if I install custom rom of android 6.0.3 marshemellow or android 7.1.1 then will they have such option or not to move app to sd or to format as as internal in both custom rom

link2sd lyf water 7 storage info


1 Answer 1


Failure [INSTALL_FAILED_INVALID_INSTALL_LOCATION] indicates something is wrong with signature.

If app is moved to MicroSD Card primary partition, Android native app2sd - settings - app - storage - MOVE TO SD CARD - created encrypted container in .android_secure directory which is mounted to /mnt/secure/asec

The same MicroSD Card cannot used in another phone without reformatting, because app2sd get in conflict with existing .android_secure directory which cannot decrypted on other phones.

You are using same MicroSD Card that's why android app2sd (asec) works for only one of both devices.

Reformat or use another MicroSD Card to fix

  • android.stackexchange.com/a/221485
    – alecxs
    Commented Sep 30, 2021 at 8:07
  • @alcexs bro thanks a lot bro I used a newly purchase newly partitioned 16gb and.newly formatted micro sd card with 16gb for testing... The error was coming previously due to I formatted the second partitioned external micro sd card in ext2 file system and when I converted back to ext4 the error stopped and the android app2sd native "move app to sd" is working through link2sd. But this native option by manufacturer vendor of device is locked disabled disappeared from Original Modified Android OS 5.1.1 lolipop settings>apps>app info. . Commented Sep 30, 2021 at 13:07
  • But after formatting micro external card 2nd partion to ext4 file system apps. Moved succesfully to micro sd card..But now when I move back moved apps to sd back to internal memory "move to phone" option in link2sd it give same error again either the internal memory is not ext4 or some mobile settings problem some other setting modified locked by vendor manufacturer may bet. Commented Sep 30, 2021 at 13:10
  • No no, this must be coincidence. app2sd moveable not depend on 2nd partition, .android_secure directory is on 1st partition
    – alecxs
    Commented Sep 30, 2021 at 13:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .