0

I am trying to use Samsung's "Smart Switch" to transfer apps from an old phone to a new phone (both Samsung S9's, both running Android v10). I followed the directions carefully but not all apps are installed on the new phone. In particular, apps I downloaded from the PlayStore were installed Ok, but none of my in-house-developed apps are installed. Is this expected behavior?

Notes:

  1. All apps were successfully transferred (I see them when I tap "Apps") but they weren't installed. Am I out-of-luck?
  2. I can manually install my apps using Android Developer Studio, but I have a lot of them and that would be a real pain.
  3. I tried a "chatting" with Samsung tech support but they were clueless.
  4. Interestingly, when I tried this a few days ago, I got messages saying that the apps were designed for an older version of Android and asked "Install Anyway?". I always clicked YES but they still were not installed. I no longer am asked this.
2
  • The Google device migration tool works the same way, apps from Play Store are re-downloaded, the rest ignored. Installing multiple apps is pretty easy if you have the APK files, just install them on comand-line via adb install <app.apk>. Even installing multiple APKs in one command is possible.
    – Robert
    Commented Oct 1, 2021 at 17:29
  • If I understand you correctly, I CANNOT migrate non-Playstore apps using SmartSwitch (?). I did try the "adb install" method and that DID work well.
    – DontPanic
    Commented Oct 3, 2021 at 19:45

0

You must log in to answer this question.

Browse other questions tagged .