1

I have tried to sync from a Linux device to Android device using Rsync Wrapper. The source file size is about 6 GB. But the problem is that the file manager shows the destination file is much smaller. There is enough space. I use --append-verify for rsync, and sometimes the resulting file just gets smaller after retry. Logs seem to show that it loaded what was expected anyway.

Rsync Wrapper version is 1.9.8 rev.27. Android version is 9.

I also tried using rsync (version 3.1.2, protocol version 31) directly over USB with MTP protocol. I had to delete the destination first, because AFAIK --append-verify does not work with MTP. Still the resulting file is too small, 1727886774 bytes reported by ls -l. I got that size before, too. Again, the log shows that the whole file was sent:

2021/10/03 09:23:23 [28652] sent 6,024,324,598 bytes  received 588 bytes  5,591,021.05 bytes/sec
2021/10/03 09:23:23 [28652] total size is 6,022,854,070  speedup is 1.00

I renamed the old destination file and tried copying in file manager. Again, copying stops at 1.7GB. File manager reports libmtp error.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Firelord
    Oct 5 '21 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.