Can't use my banking app nor pass safetynet

Completely Hid the banking app, and google store, and google services on Magisk hide. Also tried a few relevant Magisk modules:

  • Magisk Hide props config (default)
  • Systemless host (default)
  • Universal SafetyNet fix 2.1.1
  • Riru framework
  • Riru Unshare
  • Riru MomoHider

Relevant Xposed modules:

  • RootCloak
  • SudoHide
  • XprivacyLua
  • Bancontact RootBypasser

Also tried Island, and applying those modules above to the isolated app. No deal

Can't disable OEM unlock, or else TWRP is blocked by some FRP

What else can be done ?

Samsung G935F
Lineage OS 15.1 (Oreo 8.1)

Same use to happen before, with S7's original ROM

Important: I have other Xposed/LSPosed modules that I need:

  • ExSDCard Access Enabler (Magisk)
  • App Locale 2
  • Lucky+Patcher
  • Jasi Patcher
  • Disable-FLAG_SECURE
  • Greenify
  • Secure Settings
  • AFWall+

And apps:

  • Titanium backup

Second part of the question:

How can I tell HOW the app detects root ?

So I can possibly patch the leak... Block services... Make XprivacyLua more effective

Maybe this second part is the most relevant here

Third (optional) question:

Are there any updated news regarding this cat and mouse fight ? Is someone working against this hardware verification ? Having breakthroughs ?

  • 1
    Does this answer your question? Can "Magisk" hide bootloader status?
    – alecxs
    Oct 3, 2021 at 9:17
  • Yes. Answers a part of the question. Thank you for the suggestion. I was hoping that the community had a breakthrough since 2020, year of the article. No change, apparently
    – user113550
    Oct 4, 2021 at 11:05
  • 1
    Some related news from today forum.xda-developers.com/t/…
    – alecxs
    Oct 4, 2021 at 17:45

2 Answers 2


You don't need all of those modules and apps (though XprivacyLua is needed)

I can totally understand your situation so I'll explain what i did for myself. Just follow step by step and it'll work.

First things first, remove every magisk module (incuding systemless hosts,Unshare and Momohider - yes we dont need that) except Riru CORE framework.

Also remove whatever xposed module you've installed except XprivacyLua (also you should be using riru lsposed, not xposed)

Now install Riru - LSPosed, Universal safety net fix 1.2.0 (not 2.1.0)

Now follow relevant parts of this guide.

DO reset data of Play services, Play store and Google Services Framework.

Reboot and safetynet should pass.

Feel free to comment any doubts

  • Didnt work for me, even after carefully selecting only the necessary plus recommended on LSPosed/Xprivacy. Maybe the cause are my other modules (updated the thread to include them). Followed the script. Wiped every possible data from google apps AND the banking. Magisk was already rebaptized... The only thing I didn't do was to spoof the fingerprint of my device, since it's a different ROM.
    – user113550
    Oct 9, 2021 at 11:54
  • 1
    I assume your Custom ROM is using redfin or Pixel 5 props by default. I recommend changing it to your stock ROM props and following the guide again . Oct 10, 2021 at 6:42
  • Pixel 5 based. Will do that. Thank you !
    – user113550
    Oct 10, 2021 at 13:52

You should try uninstall titanium backup. Once one of my banking app detected TB and stopped working. After uninstalling TB I was able to hide root from that app

You must log in to answer this question.