0

I installed:

  • the latest platform tools from google
  • the universal adb driver
  • the OnePlus USB driver

USB debugging & OEM unlock are on.

With the phone turned on everything runs fine. I can copy files onto the device and it shows up in adb and the device manager just fine.

But when I go into the bootloader, fastboot does not list or recognize the device and I noticed in the Device-Manager the phone shows up like this. Idk if this is normal or not, but I'm out of ideas.

Any help would be much appreciated.

5
  • Screenshot of the command prompt.
    – Philippe
    Oct 8, 2021 at 15:31
  • "Screenshot" of FastBoot Mode.
    – Philippe
    Oct 8, 2021 at 15:38
  • 1
    Please don't use comments to add information, edit your question instead.
    – Robert
    Oct 8, 2021 at 16:00
  • Does this answer your question? Having issues Installing TWRP Recovery On Huawei Mediapad T3 10 from Windows
    – alecxs
    Oct 8, 2021 at 18:22
  • Note: even with signed drivers you would run into same issue, because according to your screenshots you are mixing up adb with fastboot. you simply forgot to install fastboot drivers at all, which is a common beginners mistake. Android Bootloader Interface is the solution (and how to install it) regardless it's unsigned or signed. Furthermore this is plain windows issue, fastboot works fine on linux without installing any additional drivers at all.
    – alecxs
    Oct 9, 2021 at 8:40

1 Answer 1

0

Fix Device not showing up in Fastboot Mode

So it turns out Windows doesn't like the OnePlus USB drivers because they are not signed. So you have to bypass it by disabling driver signing enforcement.

  1. install the OnePlus drivers that are included with your phone.
    --- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
  2. This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
  3. In that folder there is a driver "" but both when installed from my phone, and a downloaded version, I ran into "The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering." So next we are going to disable signed drivers on windows.
    -----Select the "Start" button.
    -----Type "startup".
    -----Select "Change advanced startup settings".
    -----Select "Restart now" under the "Advanced startup" area.
    -----Select "Troubleshoot".
    -----Select "Advanced Options".
    -----Select "Startup Options".
    -----Select "Restart".
    -----A menu will appear where you can press "7" on your keyboard to choose "Disable driver signing enforcement".
    Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
  4. Boot your device into fastboot mode. This should cause it to show up in device manager as Android, with a yellow triangle
  5. In device manager (press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
    -----Update driver
    -----Browse my computer
    -----Let me pick
    -----Have Disk
    -----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
    -----Select OnePlus_android_winusb.inf and click okay
    -----OnePlus Android Bootloader Interface should be selected, and go ahead and install it.
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .