Can someone help me? I'm really frustrated now and eating through my data like theres no tomorrow. Since I did the ICS update I can't connect my samsung galaxy s2 to my home wireless router (belkin n1)! It says obtaining ip address...authenticating...saved secured with wpa/wpa2 psk and then repeats over and over again! But no Wi-Fi, and I cant get online etc...

Does anyone know what would cause this? How do I fix it?

  • How did you perform the update? via KIES or some other method? Check to ensure in the Wi-Fi settings you haven't specified a static IP address for your phone. And that your router isn't configured to disallow/allow certain IP addresses or MAC addresses.
    – Sparx
    Jun 14 '12 at 18:11
  • ive forgot the network and done it manually and same thing occurs... i tryed wifi fixer app and still no joy
    – Rachael
    Jun 15 '12 at 9:52

What steps have you undertaken to resolve the problem?

Some suggestions:

  • Try restarting the phone
  • Try removing the network entry ("Forget Network"), then add it again. Please make sure that you have the necessary information to reconnect before doing this.

edit: related Question

  • i done the update on work wifi then battery drained so i finished the update at a friends house! ive been told theres no need to set up a static ip! definatly something to do with settings on my belkin n1 router can someone please hase a look for me its driving me mad!!!
    – Rachael
    Jun 15 '12 at 9:51
  • The way I understand your comment, the upgrade was interrupted?
    – seeker
    Jun 15 '12 at 11:20
  • yes well split if you like... because my battery drained i had to finish the update when i had a full charge. never had any problems with connecting to my home network before... i can connect to anything else but my own...it literally finds the network shows its connected saved etc but dosnt let me online :S ... its a belkin n1 wireless router and i really belioeve its something to do with the settings on it. i may try typing ip address into homebar and messing around with secuity changing to aes i think i got it on tkip at the min. someone also mentioned changing b+G+N setting to n only????
    – Rachael
    Jun 15 '12 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.