I just want to check whether bootloader is locked or unlocked. I am using Minimal ADB and Fastboot which I downloaded from here. I am following instructions to check bootloader from this website. Everything is fine until I enter into Fastboot mode on my phone. (I enabled USB Debugging and revoked usb debugging authorization in Developer Options). I can see my device after running adb devices in cmd. But when I run adb reboot bootloader command, it just reboots in normal mode. It doesn't enter to fastboot mode. I aslo tried adb reboot fastboot but it also didn't work. That means when I type fastboot devices, I don't see anything.

What should I do to enter Fastboot mode so that I can run fastboot oem device-info to see my bootloader information?

Note: My phone is Oppo F11 and it is running Android 11. I am not familiar with adb commands.

  • 2
    Welcome to the wonderland of Android. Every device model can be different. The main problem is to identify if this is an unusual problem of your device or if all Oppo F11 don't have fastboot mode. Unless by chance one of the other users owe an Oppo F11 you are out of luck here. There I would recommend you to better ask in the Oppo specific forum ad XDA developers forum. There the chance should be greater to meet someone with experience with your phone and who knows if this is normal bahavior or not.
    – Robert
    Oct 18, 2021 at 19:37
  • @Robert Also my phone is not rooted. Can it be a reason? Oct 19, 2021 at 6:15
  • No fastboot/bootloader mode works no matter if your phone is rooted or not.
    – Robert
    Oct 19, 2021 at 6:17

1 Answer 1


Oppo F11 has non-unlockable bootloader, fastboot is disabled intentionally. You can root with bootless-root method only, but carefully read instructions especially respect all warnings

  • Thanks alot man. I needed to know it because I think my oppo f11 has any undetectable malware or backdoor and someone said if a phone is running stock ROM and bootloader is locked, those kinda virus will be gone if you reset your phone. Oct 19, 2021 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .