I have a shieldtablet which was working fine, until I decided to encrypt the drive. The process completed, the device rebooted, and it's stuck in a reboot loop. Neither Linux/Windows recognize it when the USB is connected, and it's not listed/identified via the adb or fastboot utilities. I can enter TWRP recovery and the bootloader (nvboot), but it doesn't look like I can push any files to the tablet or flash.

edit: Fortunately the tablet accepts the sdcard, and it looks like I am able to install files via TWRP. I did attempt to format and install LineageOS 16 through it, but the issue remains (lineageos boot animation plays for 1-2 minutes, then the device reboots).

Potentially critical info: When I enter the bootloader, nvtboot versions shows a single glyph (garbage) character (although the bootloader reports version 4.00.2016.04-8b2413b7). Is it possible that the encryption broke the bootloader or some other important partition/data?

Do you have any ideas for further debugging so that I can salvage the tablet?

  • 1
    TWRP -> Wipe -> Format Data -> type "yes" (reboot recovery and repeat)
    – alecxs
    Oct 22, 2021 at 7:10
  • 1
    Does this answer your question? Cryptfs : Unexpected value for crypto key location
    – alecxs
    Oct 22, 2021 at 7:13
  • Thank you @alecxs. Hmmm dmesg and recovery log don't show any such errors. I also ran a grep -i for cryptfs, nvt etc but didn't find any logging of interest.I tried again with "Format Data" and an advanced wipe, I rebooted again before trying the installation, and strangely enough this time it worked. Last time I installed right after formatting. I recall that I set TWRP to leave the system partition as writeable (not read-only), so I'm not sure what changed from last time! The fact that nvtboot still doesn't show a proper revision/ver still worries me, but at least the OS boots!
    – Astyanax
    Oct 22, 2021 at 14:55

1 Answer 1


"Format Data" via the TWRP recovery -> Advanced Wipe -> Reboot -> Reinstalling LineageOS 16 seemed to do the trick, and the OS now loads.

(Interestingly, I still cannot identify the device via adb/fastboot, I wonder if the stock ROM will resolve that).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .