2

I have SmartLike Lyf Water 8 LS-5015 with Android 6.1 Marshmallow vendor updated. I want to take NAND backup before rooting through loading TWRP recovery in fastboot mode (fastboot recovery twrp.img).

I tried with 3 TWRP recovery images listed below: one is TWRP 2.8.4 recovery image from the official TWRP website and the other two are from XDA.

However, all give the same error of mounting 0MB storage in the backup menu as not able to select any of the destination drives for saving NANDROID backup system.img, boot.img, data.img to storage.

twrp backup menu destination storage 0 mb error

  1. Official TWRP - TWRP 2.8.4

  2. [XDA - [TWRP]RECOVERY][LS-5015] For Lyf Water-8

  3. XDA - [UPDATED] [Recovery] [Unofficial] TWRP 3.1.0-0 for LYF Water 8 (LS5015)

After searching and googling, I found that it's been encrypted and I have to decrypt it. The solution is as below with links:

  1. Appuals - How to Fix TWRP Unable to Mount Storage, Internal Storage 0MB

Above link says

  1. The first thing to try is if somehow your internal storage became encrypted when using a legacy screen lock method.
  2. Go to your Android device’s Settings > Security > Screen Lock, and change your screen lock method to either Pass or Pin. Create a new one.
  3. Reboot into TWRP, and it should ask for a password – enter the pass or pin you just created.
  4. TWRP will attempt to decrypt your device’s internal storage, and if it succeeds, you should not have further issues. However, if this does not solve your issue of “unable to mount data, internal storage 0mb”, continue with the rest of this guide.
  5. Reboot your device into TWRP again.
  6. Navigate to Wipe > Advance Wipe > Data, and choose Repair or Change File System.
  7. Press Repair File System to see if this fixes the issue. If not, continue.
  8. Press Change File System, choose Ext2, and swipe to confirm.
  9. Now switch back to Ext4 and swipe to confirm.
  10. Go back to TWRP main menu, then the Mount menu, and check if your partitions can be mounted now.
  11. If you are still unable to mount your partitions, you need to repair Internal partition, which will most likely wipe your internal storage.

The password PIN I put in the screen lock is never asked if I boot the two recovery images in fastboot mode (fastboot recovery twrp.img)

  1. XDA - How to fix unable to mount data internal storage 0mb in twrp permanently :

Note : This will wipe/format your Data partion and your data will be reset.

INSTRUCTIONS :

  1. Reboot your device into TWRP Recovery.

  2. Go to Wipe menu.

  3. Go to Advance Wipe.

  4. Select Data and go to Repair or Change File System.

  5. Click Repair File System. (If not fix, go to step number 6)

  6. Go to Change File System.

  7. Select Ext2 and swipe to confirm.

  8. Now change back to Ext4 and swipe to confirm.

  9. Now go back and check if your partions can be mount or not from Mount menu.

  10. If not fix, repair your Internal partition. (This may wipe your Internal storage).

OR Unlock your bootloader again.

As per the wipe option, I tried to repair the file system of /data or external HDD card, it gave the following errors as the screenshot below

twrp recovery wipe menu  repair file system errors

Any solution for solving the two mounting problems of decrypting or converting the file systems?

8
  • if TWRP is not capable to decrypt, use Migrate for backup instead
    – alecxs
    Nov 4, 2021 at 7:19
  • please share /tmp/recovery.log
    – alecxs
    Nov 4, 2021 at 11:32
  • @alecx bro thank migrate for backup is option in two or any another app tool or advice command kindly guide how to use Nov 6, 2021 at 14:27
  • @alecxs bro "/tmp/recovery.log" i can't find any folder /tmp/ in root as phone is not rooted and it decrypted it's /data/ and /system/. Folders are showing access denied from xplore file manager..Kindly guide how and where to locate /tmp/recovery.log folder or file Nov 6, 2021 at 14:32
  • @alecxs bro is there any adb. Shell command or fast boot commands or third party app (works on not rooted phone) that can decrypt the encryption of /data/ or in twrp old version any way to decrypt the data folder temporary for.backup .....I tried adb pull command for userdata but it's not working even ls -l command not working to show device. List....Any solution Nov 6, 2021 at 14:37

1 Answer 1

0

I had a similar problem just now, having installed LineageOS on a Xiaomi tablet.
After installing the OS, the device was unable to load into it. It only showed the Mi icon, and shortly flashed black, repeatedly; seemingly stuck in a short loop.

At that point, only my external SD card could be read by TWRP.

What helped me out, was this simple comment from Bartnl on the OnePlus community forum:

  • Restart TWRP (in TWRP: Reboot -> Recovery)
  • After having restarted, go to Wipe > Format data, and type 'yes'

Now your internal storage is formatted and you can access it from a PC.

In my case I rebooted and the device loaded into LineageOS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .