I've got an HTC One X, on which I'm trying to record uncompressed WAV audio.

In particular, I'm interested in a 13.5 kHz sound. Other Android devices pick up that frequency easily, and so do iOS devices, but the HTC One X doesn't.

For example, the spectrogram below shows the same recording from the HTC One X (top) and an HTC One V (bottom), recorded with the same app (called Hertz, but any will do), with identical settings (mainly 44,100 Hz sampling rate).

Why is the One X not picking up the same?

  • Is the microphone different?
  • Is there any low-pass filter applied that I'm not aware of? If so, how can remove it?

Trying with different apps (e.g. Audalyzer) doesn't make any difference.

Frequency Response

2 Answers 2


It doesn't say it on HTC's website under the specs for the One X, but this review points out that the phone has dual-microphones, used for sound cancellation during phone calls. My guess is perhaps your recording app is recording from the wrong microphone? Or using both to cancel out the pitch you're looking for?

I'd look for settings in your recording apps about using the dual-microphones. I don't have a phone with two, so I can't test that for you :/

Good luck though!

  • Thanks for the insightful comment, I didn't notice that about this phone. Unfortunately I haven't yet found an app that can let me choose what mic I want to use, nor any settings that would stop the filtering.
    – gozzilli
    Jun 17, 2012 at 15:29

I have the same issue. After playing around with One X a little bit I'm pretty sure the issue is with the noise cancellation thing, most likely software issue.

There are 2 microphones on the One X - one at the bottom and one at the top. I played a high frequency sound on my earphones and tested 2 cases:

  1. I put both speakers next to the bottom mic. Sound level was very low, but it was there.
  2. I put one speaker next to the bottom mic and one next to the top mic. This time sound level was pretty much 0.

So it seems that what the top mic picks up is cancelled from what the bottom mic picks up. I haven't figured out how to disable this feature.

Any luck on your side?


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .