My phone is rooted with aokp build 38 on it. It is a Verizon Galaxy Nexus (toro)

There is a folder /sdcard/data that I can't make any changes to. Some of my apps are trying to use this folder but are not able to because any changes to this folder fail.

I tried deleting it but was unable to. I even used adb shell with root access and tried to rmdir, but it says "Permission Denied"

I also tried to chmod 777 to give full access to the folder, but I still was unable to make any changes to it.

I'm at a loss as of what to do to make this directory writeable again.


Make a backup of your data first.

every folder and file in the /sdcard/data directory is 0 bytes.

This looks like a corrupted filesystem or a defective sdcard (see correction). Especially, folders have a usual minimum size of 4.0K.

I'd suggest you to back up your data first, then check for errors:

Does "dmesg" show filesystem errors on mmcblk0 or similar?

If so try to backup, reformat sdcard (see correction) and restore or replace the faulty sdcard.

(EDIT) Correction:
The Galaxy Nexus has no SDCard but a unified EXT4 filesystem for /data that also includes /sdcard (which is symlinked to /data/media). You might solve the problem with a wipe. But that will also delete all of your /sdcard content too.

You might have luck entering recovery and adb'ing into it to fsck.ext4 your /data partition, I'm however not sure if your rom supports this command

# boot to recovery first!
adb shell
cat /proc/partitions
# look for the biggest one and replace the ?? accordingly
fsck.ext4 /dev/block/mmcblk???

Here's an external report about a similar issue:


  • How do I get adb to recognize my device when it's in recovery? It always says device not found. (I feel like it should just see it, but maybe I'm wrong.) – Aaron Smith Jun 18 '12 at 12:40
  • Some recoveries don't start adb internally but offer an option to do so in the menu. If adb is missing altogether you can start a different recovery temporarily: download a recovery image from clockworkmod.com/rommanager and boot to fastboot mode. Then execute 'fastboot boot <recovery-...img>' Adb should work until the next reboot then – ce4 Jun 18 '12 at 13:22
  • I ended up just restoring to stock. I'll reflash a custom ROM later. I couldn't get my computer to recognize the phone when I was in recovery. I believe your answer was correct though so I'll mark it as such. – Aaron Smith Jun 18 '12 at 18:09

Try going to /data/media, it should be the same folder as /sdcard. I think the files you're trying to delete might be virtual, I had this exact problem while trying to clean up in /sdcard/Android/data until I realized that I could also find them at the path specified.

  • what are 'virtual' files on a vfat/ext4 partition? the 0-byte sizes of folders are a rather clear indication of fs problems, most probably some directory inode is not accessible/parseable and gets stuck at 0 byte.# – ce4 Jun 25 '12 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.