1

I have an ASUS Zenfone Max Pro M1(X00_TD). Lately, I have noticed that my phone's downloading or uploading speeds don't go over 10 to 15 Mbps. It has a 2.4 G wifi and easily used to give me 40-60 Mbps 2-3 months ago. But now I don't know why the speeds never go above 15 Mbps.

Initially, I thought my ISP maybe down or the server may not be giving off above 15, but I cross verified it 50 times with other devices.

It doesn't go above 15 Mbps even on cellular data.

The ISP is fine(100 Mbps). It doesn't go above 15 even in speed tests. How can I fix this? Thanks in advance

7
  • Try clearing download manager's cache and data (it's a system app and you will need enable "show system apps" in app listing //If that doesn't help try a download manager from Play store // last resort clear wifi data//If nothing helps verify if the behavior is same in safe mode (Google how to enter safe mode for your device)
    – beeshyams
    Commented Nov 19, 2021 at 4:59
  • Nothing helps, and the behaviour is the same in Safe Mode. What to do? @beeshyams
    – Saki Osive
    Commented Nov 19, 2021 at 6:33
  • If it is the same device which is mentioned in your previous question, I would backup data and do a factory-reset
    – beeshyams
    Commented Nov 19, 2021 at 6:43
  • 1
    Trying the same now. Thanks.
    – Saki Osive
    Commented Nov 19, 2021 at 7:58
  • 1
    Thank you so much, will go to the service center. @beeshyams
    – Saki Osive
    Commented Nov 19, 2021 at 13:56

1 Answer 1

0

The issue got fixed, the issue was with the ROM. I had flashed a stock ROM from ASUS' website a month or so ago and due to that even factory resetting didn't help. I flashed a new Pixel Experience ROM on it by unlocking the bootloader and it fixed the issue. I'm now getting full speeds, 50 Mbps+

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .