-1

How do I run a GitHub project written in C language? I’m using a Terminal emulator (Termux for Android), so I’m trying to install & run a GitHub repo.

Using Termux, it goes like this:

gh repo clone arcanecfg/Instagram-Private-Scraper
cd Instagram-Private-Scraper

I've tried several packages (npm, mono, clang, gcc) in order to compile & run the script, nothing works. I’m completely lost. the GitHub project has .cs and .csproj files which (I guess) I’m gonna need Microsoft Visual Studio on my PC.

1
  • 3
    GitHub shows that this project has 100% C# code which means it is a dot.net program. As it is 4 years old without any commit it bases most likely (no real documentation) on Dot.net for Windows. So you need Visual Studio or at least Dot.Net SDK for Windows to compile. Mono may also work but you may need some C# experience to adapt and compile it. But as it is unmaintained the chance that it would still work is next to zero as web sites like Instagram usually don't leave their pages the same for four years.
    – Robert
    Nov 23 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.