5

I have a 4GB SD card which is partitioned into 3GB and 1GB (Well it's not 1GB it's approx. 750 MB) (I used it through my phone 'cause i didn't have a reader and i used mini tool partition wizard) then I put my data back onto the 3GB partition. Link2SD showed me a screen titled :"select the file system of your SD card's second partition" which has 4 options:

  • ext2
  • ext3
  • ext4
  • FAT32/FAT16

The 1GB partition is ext2 so I choose ext2 and restarted my phone. It showed the same message every time and it tells me "If you're getting this message after reboot it means that the second partition cannot be mounted automatically at boot"

My phone is a rooted Vodafone 858 Smart / Huawei 8160 it's running CM7.2

I tried to reformat and repartition but nothing worked.

  • What does logcat say? Try to 'adb shell' into your device and see if your 2nd partition is the 750gb ext2 one: 'cat /proc/partitions', you should see /dev/block/mmcblk0p1 and /dev/block/mmcblk0p2. In a second step, try to mount your 2nd partition manually. 'mkdir /mnt/sd-ext' then 'mount -t ext2 /dev/block/mmcblk0p2 /mnt/sd-ext' – ce4 Jun 16 '12 at 15:38
  • i tried what you told me i found /dev/block/mmcblk0p1 and /dev/block/mmcblk0p2 but the problem is in the second step i tried "mkdir /mnt/sd-ext" and it told me "can't create directory /mnt/sd-ext : read-only filesystem" so i tried to remount it using "mount -o rw,remount rootfs /mnt" but it told me "mounting rootfs on /mnt failed : invalid argument" – Mohamed Essam Jun 17 '12 at 11:37
  • oh, sorry. Just use a writeable fs for the target. Try /dev/sd-ext (it's a temporal location that's forgotten after reboot) and mount there – ce4 Jun 17 '12 at 12:14
  • 1
    i tried that and link 2 SD showed me the same message – Mohamed Essam Jun 17 '12 at 12:53
  • Hi Mohamed, missed you yesterday, let's see in chat or just reply here... – ce4 Jul 16 '12 at 22:53
3

Requirements:

  • have a SDcard with a second partition that is ext2/ext3/ext4/... formatted.
  • be sure /data/sdext2 exists
  • be sure that mount-scripts are in place (menu->more->recreate mount scripts in link2sd)

If unsure, do as root via adb:

df | grep sdext2 should show you a mounted ext2/ext3/... mmcblk0p2 partition

  • but it has to quick reboot from link2sd after each real reboot – Mohamed Essam Jun 17 '12 at 14:13
1

In my case, I had formatted the partition of interest in ext2 and used on a CM 10.2 build.

I rolled back to CM 7.2 and selected the default ext2 but it wouldn't work.

After rebooting and having the same problem, I selected the ext4 file system and voila!

0

For CM7, you have to choose ext3 (for CM10.1 and 10.2, none of them works for me).

  • 1
    Please, no leet-talk here. – Izzy Jan 20 '14 at 7:03
0
  1. Try making second partition using your clockworkmod recovery. If it does not help got to step 2.
  2. Ensure that the format of the second partition is not automatically changing itself. To do this you can follow the following steps:
    1. Insert your memory card into your pc with help of a memory card adapter.
    2. Download , install and run mini tool partition wizard.
    3. Backup important stuff from your sdcard.
    4. Delete every partition on your sdcard and click apply.
    5. After that recreate your desired partitions. This time it won't revert to ext3.. Now you must try to use link2sd and see if the problem is resolved. If not, go to step 2.
  3. As described by NaraRockingMyAce at an xda forum :

    • With help of MiniTool Partition Wizard delete only your second
      partition on sd card. (use sd card adapter, don't do it through data cable).
    • Create the 2nd partition again and make sure to set it as primary.
    • Apply and verify if the problem is resolved.
0

that problem (link2sd unable to properly recognized partition) will and has happened to people who used modified link2sdPLUS. make sure you are using the actual free version or download the free version and pay for actual Link2SD_plus. that's what I've learnt :D

  • 1
    Would you please mention the link (edit) for the "actual free version" where the reader (if willing) can pay? – Firelord May 20 '15 at 9:19
0

I struggled getting the ext4 partition to mount. I saw the answer from denny mihai above that emphasized the need to have the partitions in the correct order. Mine were ext4 first and fat32 second. I used minitool to delete the ext4 partition, move the fat32 and then create a new ext4 partition (making sure it was a primary) . My partitions were then in the order described by Denny. On the next reboot of the Android tablet, link2sd mounted the ext4 with no further configuration. Thanks goes to Denny.

0

Fat32 partition must be set as first partition, and ext2,ext3,ext4 set as second partition. It is very important that they be in that order.

After, make sure that you have all partitions set as : primary.

Finally, try all ext2,ext3,ext4 - only ext4 worked for me!!

Good luck!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.