1

I have a Samsung Galaxy S8 SM-G950U that I used with Verizon. I moved to Japan and got a Japanese SIM card through SoftBank and used in my Galaxy S8 without a problem. My account has a global roaming service included. I came back to the US with the Japanese SIM card and was told it would work in the US but it is not connecting to a network.

'Settings' > 'Connections' > 'Mobile networks' > 'Data Roaming Access' is on.

'Settings' > 'About phone' > 'Status' > 'SIM card status' shows "Network not available" even though I have 4 bars of signal strength. Also "Not roaming" is shown but I assume I would be roaming since I'm outside of Japan.

I called a support number and they told me to go into "SIM App" to update the SIM card but I cannot find this app or setting. If I search for "SIM App", I get a result in 'Apps' > 'App info' > 'Sim App Dialog' but my only option there is 'Force stop'.

I can connect to wifi but I would like to be able to connect/use mobile data when wifi is not available.

3
  • Just using WiFi doesn't require a Cellular plan. You need to be able to connect to a Network, and enable Data. You can use the 🌄 Icon to upload a screenshot. What do these screenshots show - blank out private information before uploading.
    – Rob
    Nov 28, 2021 at 5:12
  • 1
    This might not be an issue with Android, but perhaps you need to have a subscription to Global Roaming Service on SoftBank?
    – Andrew T.
    Nov 28, 2021 at 9:02
  • 1
    @Rob Thanks for the lead. Manually selecting a network operator was the solution. Nov 29, 2021 at 13:30

1 Answer 1

2

I had to go into Settings > Connections > Mobile networks > Network operators and manually select a network.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .