For a Pixel 3a XL with an unlocked bootloader, I tried to flash a boot.img file patched by Magisk following this guide, using bonito-sp1a.210812.015 from Google Factory images.

After I successfully completed the whole process from "Step 2: Rooting Google Pixel 3a XL" section and rebooted, my Pixel became stuck booting with a "G" logo (and progress bar animating).

I tried to fix it with these commands, which resulted in always booting in Fastboot Mode, error message "No valid slot to boot".

./fastboot flash boot_a "boot.img"
./fastboot flash boot_b "boot.img"

How can I make my Pixel boot normally again without loosing any of my user data living on it?

Alternatively, is there a way to back up all my user files from Pixel with eg. adb, given the broken booting?

I'm able to boot in recovery mode if it can be useful.


1 Answer 1


Sideloading in recovery mode with full OTA following the official instructions solved my problem: Pixel now boots properly; all my data is intact.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .