I'm on a OnePlus 9 Pro using Android 11 and version of the Google App. I really enjoyed the Google Discover tab and would use it many times a day on the phone. A few days ago, it simply stopped working. When I swipe over to the screen now, I get the following error:

enter image description here

I've hit the "Try again" button, as well as swiping down from the top to reload. Same error.

I've also checked the app settings to see if something got flipped somehow. Here's the general settings:

enter image description here

Here's what I know so far:

  • This happened the second I traveled from Seattle to Texas, and took my phone off airplane mode. Right when I went to the Discover page, I got this error. This was 3 days ago. I have no idea if this error is location based or just a random coincidence. I guess I'll find out when I get back to Seattle on Friday.
  • I've tried things like clearing the app cache from the Google app, and removing all Google App updates and re-installing them in the Play store. No go.
  • If I log off and choose the "Use without an account" option, the feed loads. However, then I would get random links in which 99% of them I couldn't care less about. The links associated with my Google account were generally very useful, except when it would spoil who won on The Great British Baking Show even though the finale hadn't even aired in the US yet.
  • If I use without an account, then log on as myself again, I'd get the same error.
  • I'm using a paid, Google Suite (I think it's called Google Workspace now?) account with a custom domain name. I do not have have an @gmail.com address of any sort. I'm actually leaning towards this as a primary suspect, even though I haven't changed any settings. Google has made it clear many times in the past that paying users are second class citizens, as many products don't work, and you can't do things like "Rate an app" in the app store even though every app always pops up asking for ratings. I dug through the enabled apps in the admin console and didn't see anything about Google Discover or Google Now. The only apps that were disabled didn't appear to be related. Maybe there's some weird setting buried in there somewhere though. It's also possible Google just decided to disable Discover for paid accounts, which wouldn't surprise me in the least. I'd expect this to have been announced or documented somewhere, which I wasn't able to find.

I'd love any ideas on things to try! I've read just about every link and blog post I could find online, but they're generally fairly useless. It's also been suggested you can get the same feature from the "New Tab" page in Chrome. This is true, but it only shows a few things at a time. I'd love to be able to get the phone working like it did a few days ago.


I talked with a Google Workspace support rep and he has confirmed this should work, and all admin settings in my account are correct. Beyond that, he wasn't able to tell me why this isn't working. Since this is not a Google Workspace issue, he wasn't able to escalate any further.

  • These might help: toggle WiFi / cellular data off and on, force stop Google Play services, restarting your phone
    – crazo7924
    Dec 8, 2021 at 16:56
  • @crazo7924 I'll try that. I did try restarting the phone several times already. Dec 8, 2021 at 17:03
  • @crazo7924 Ok just tried that. Still same error. Dec 8, 2021 at 17:07

1 Answer 1



The second I got back into Seattle, everything started working again. So, this problem is most definitely location based. Either Google Discover does not work in Texas, or something about my account prevents it from working in Texas. This theory fits in with a reply from a product rep in this thread, saying the issue can be solved by VPN'ing into another network. As VPNs basically "mask" the real location, this is perhaps another way to work around the issue. Now I'm kinda wondering if I could have fixed this by turning off Location services as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .