1

I've been trying to install custom ROM on my device.So first I went to install TWRP. My device is Infinix Smart 2 X5515F. I followed the steps from this website. I'vd downloaded the TWRP file for my device and tried to flash the file from fastboot mode, using the commands given on the site. But each time I tries to boot into recovery by fastboot boot twrp.img it does nothing. So I tried to get into recovery mode manually. I first rebooted the device using fastboot reboot and then shut down the device. Then I pressed power and volume up buttons. It took me to a window with a text of(no commands). I pressed volume up and power button once again and it took me to systems default recovery. The default one was not replaced by TWRP. Also each time I do the procedures it factory resets my device. Do anybody know any solution to this??

11
  • Have you unlocked the bootloader? Or otherwise, which step from the link are you stuck on?
    – Andrew T.
    Dec 9, 2021 at 15:48
  • Yeah, I think so. Because each time I reboot the phone it shows message like your phone is unlocked and can't be trusted. Dec 9, 2021 at 15:52
  • which command should i use to unlock bootloader? Isn't it fastboot flashing unlock Dec 9, 2021 at 15:53
  • @AndrewT. first of all the site said me to unlock OEM by fastboot oem unlock. The command unfortunately wasn't understood by the device. So I went to the next step. I flashed the file and ready to boot into recovery by using the command fastboot boot recovery.img but it didn't work for me. Dec 9, 2021 at 15:56
  • You have to unlock the bootloader first before being able to flash custom recovery. On some sites, I read that you have to enable "OEM Unlock" from the Developer Options first before calling fastboot oem unlock or fastboot flashing unlock. However, not having the device in hand, I can't tell if the articles are correct or just clickbait.
    – Andrew T.
    Dec 9, 2021 at 19:23

0

You must log in to answer this question.

Browse other questions tagged .