0

I'm using Android 12 on a Google Pixel 3. My default browser is Brave. I sometimes also use Chrome.

For many types of links, such as https://www.linkedin.com/feed/update/urn:li:activity:6883161994237636609/ , my phone correctly opens the content via the related native app (in this case, LinkedIn).

I want all YouTube URLs to open via the YouTube app and thought my settings (shown below) would enable this behavior; what is wrong?

Although many similar questions have been asked before, their old answers haven't helped me in 2022:

You can see that my settings look appropriate here:

P.S. YouTube URLs within email messages in my Gmail app do open the YouTube app correctly.

4
  • Your picture doesn't show the links that the Youtube app must/should open. Jan 2 at 21:33
  • @ReddyLutonadio I hadn't mentioned the links that the YouTube app is configured to open because they aren't configurable. However, since you asked, I just added a screenshot. Thanks.
    – Ryan
    Jan 3 at 1:52
  • 2
    Can you try disabling “Video playback in Brave” under Settings > Site settings > Media?
    – MANI
    Jan 3 at 13:40
  • @MANI I think that might be the answer! It has worked so far (I just tried clicking a YouTube URL within a Google Doc, and it correctly opened the video in the YouTube app). You could post this as an answer. I will mark it as the accepted answer in a few days if I don't see the problem recur. Thanks so much!!
    – Ryan
    Jan 3 at 14:20

1 Answer 1

2

This is for Brave Browser only and the navigation that is shown below might change in the future because who knows ¯\(ツ)/¯.

Try disabling “Video playback in Brave” under Settings > Site settings > Media

PS: Similar settings are available in most popular browsers, messaging apps, etc. All you have to do is fiddle around the settings. And most settings won't break/harm your phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .