I have a OnePlus 7Pro (GM1917) that was working fine for a long time with OOS 10.3.8. Its bootloader is unlocked, and it was rooted. I hadn't upgraded it for a long time, and recently I decided to flash an A11 ROM: OOS At that point, I lost all ability to access the /data partition.

I know that there can be similar issues with such an A10-to-A11 upgrade, and that many of these issues are solvable. However, I have investigated and tried many things to fix this, to no avail, and I fear that my problem goes deeper than those issues and might not be fixable. But I'm hoping that there might still be something which I haven't tried that could fix my problem.

Here is a detailed description of everything I did, how it all failed, and everything I have tried so far to fix it ...

After the A10-to-A11 upgrade, my device went into a permanent boot loop when trying to boot to System.

I then did fastboot boot twrp-3.6.0_11-0-guacamole.img (which is the version of TWRP that is meant to work with this OOS ROM), and this indeed put me into TWRP. However, the /data partition is inaccessible. Whenever I try to format /data, I consistently get these messages:

Failed to mount /data (Invalid argument)
Unable to recreate /data/media folder.
Unable to mount storage
Unable to mount /data/media/TWRP/.twrps
Unable to wipe data

I then went back to the bootloader, and I ran these commands:

fastboot erase userdata
fastboot format:ext4 userdata

These commands successfully run with no error messages. However, when I then go back into TWRP, /data is still inaccessible, and I get the same error messages that I listed above when trying to format /data .

I then tried to decrypt /data, but when I do so, it asks for a password, and I have no idea what password to give. I never used any password on the device in the past. I am not allowed to decrypt /data without a password.

So, I decided to use the MsmDownloadTool to reflash my device back to OOS 10.3.8. This works fine with a different GM1917 device that I have (but which I never tried flashing to OOS 11). However, with this particular device, after going into EDL mode, I am told that I am "Connected", but a couple seconds later it gives me the "Sahara Connection Failed" message. I have double-, triple-, and quadruple-checked the device drivers, and it indeed is showing that the Qualcomm qds 9008 driver is properly installed and active on the PC. Furthermore, as I mentioned, I have no problem using MsmDownloadTool on that same PC with another GM1917 device.

I then went further: I extracted payload.bin from the OOS installation bundle, and I extracted all of the *.img files. I flashed boot.img via fastboot and retried everything that I mentioned above, but nothing has changed.

I then went and flashed all of the *.img files via fastboot. However, still nothing has changed.

When flashing the set of all *.img files, in some cases, I was told that the file is critical and cannot be reflashed. I then ran these two commands ...

fastboot flashing unlock
fastboot flashing unlock_critical

... but in both cases, I am told that the device is already unlocked. Trying to flash all of the *.img files again gave me the same results: i.e., some got flashed, and others were not flashed due to being "Critical".

Also, some of the items I flashed were said to be "sparse", and their flashes were flagged with warnings, but as far as I can tell, they seem to have been flashed anyway.

In the end, I still go into a bootloop when booting to System, the /data partition is still inaccessible, and EDL mode still does not function.

Do these problems with /data and EDL and everything else mean that my device is somehow permanently damaged? Or are there perhaps one or more additional things that I can try in order to restore it to some sort of working state?

Thank you in advance for any thoughts or ideas.

2 Answers 2


The problem with /data has now been fixed.

I had forgotten that in the past, I was trying the OrangeFox dual-boot recovery on this device, and it had repartitioned /data.

I fixed this by flashing the appropriate *.img files again for my OS (OOS 10.3.8), and then by booting into the standard OrangeFox recovery (the non-dual-boot version) via fastboot, and then by using its adb sideload facility to flash that same OrangeFox recovery. OrangeFox's adb sideload mechanism offers options to the user for repartitioning and rebuilding /data. I utilized those options and set /data back to "Stock", and after that, /data became accessible again, and I could format it and access it in recovery with no problem.

At this point, I flashed OOS 10.3.8, and I then flashed the appropriate TWRP and Magisk. Now, my device is back up and running in that OOS version.

The EDL problem continues, but given that my device is now usable again, I am not overly concerned about this MsmDownloadTool issue at the moment. In my spare time, I'll continue to look into that.

All's well that ends well! ... and now it's indeed a happy New Year for me!


While I don't have a perfect answer for you, I can at least provide some info on MSMDownloadTool. I've resolved that Sahara Connection Failed issue through a couple of ways:

  • Changing the USB port I am connected to
  • Reattaching my device
  • Restarting the program

MSMDownloadTool seems pretty finicky. I usually get stuck in a loop where it completes and then restarts the flash, locking my phone into EDL mode. I'd recommend flashing via fastboot or recovery before resorting to MSMDownloadTool. I've had some luck directly flashing the OTA Updates that OnePlus provides.

  • Thank you very much. Unfortunately, I tried those same things numerous times with MsmDownloadTool, and unfortunately, that problem persists. However, I managed to fix the problem with /data! See my Answer, which I am now posting.
    – HippoMan
    Jan 3, 2022 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .