I am struggling to flash lineage-14.1-20181216-nightly-i9100-signed.zip , on a old S2

the installation gets stuck both with adb sideload and manual 'install' on TWRP, with message on phone logs patching system image unconditionally

I tried heimdall flash, following this reddit post but I get the error: ERROR: Protocol initialisation failed!

any idea?


ps: also, fastboot does not see any device

  • it might be a system partition size ... (?) given that on phone it's 503 MB, while the whole LOS folder is 561 MB ...
    – jjrr
    Commented Jan 4, 2022 at 14:05
  • maybe this could help ? android.stackexchange.com/questions/216123/…
    – jjrr
    Commented Jan 4, 2022 at 14:05
  • actually I try the steps recommended there, but I get adb: error: cannot stat parted: No such file or directory
    – jjrr
    Commented Jan 4, 2022 at 14:08
  • 1
    Based on the Reddit thread, I think you're right that the system partition is too small. Samsung is a bit different than other manufacturers, so I'm not sure parted may work. Btw, I read the continuation on that Reddit thread where they successfully repartitioned using heimdall and correct PIT file. Have you tried that instead?
    – Andrew T.
    Commented Jan 5, 2022 at 3:52
  • thanks! I think I managed to install it, by looking at the charging logo ... but the OS still does not start :/ forum.xda-developers.com/t/…
    – jjrr
    Commented Jan 5, 2022 at 21:26


You must log in to answer this question.

Browse other questions tagged .