1

I have a Moto Z2 Play device (android 7.1.1) that was rooted with Magisk (v20.1) with Magisk Manager app (v7.4.0). Magisk Manager Hiding feature was also activated.

When I deactivated the Magisk Manager Hiding:

  1. Magisk Manager v7.4.0 got auto updated to v22.1 and Magisk was shown as not installed
  2. Selected direct install option in the app to install Magisk (v22.1)
  3. Rebooted the Moto Z2 Play device

And the device failed to power up... Is there any way to fix this?

I have tried Fastboot boot to TWRP and flashing Magisk-v20.1.zip but to no avail, device still doesn't start up normally when I press the power button. Currently I can still boot into fastboot/recovery mode.

3
  • flash stock boot.img to repair what magisk broke
    – alecxs
    Jan 10 at 10:20
  • Thanks @alecxs, would there be any difference between flashing stock boot.img and flashing stock rom?
    – huthut28
    Jan 11 at 11:49
  • does not harm but not necessary as magisk does not modify system
    – alecxs
    Jan 11 at 14:34

1 Answer 1

0

UPDATE: @alecxs answer worked for me, still trying to figure out how to accept it as the answer.

Apart from flashing stock boot.img, I also flashed magisk v20.1 uninstaller and reflashed magisk v20.1 installer to fix the booting issue.

  1. Flashed stock boot.img using fastboot flash boot boot.img -> device now powers up, but goes into boot loop
  2. Flashed magisk v20.1 uninstaller via TWRP -> device still goes into boot loop
  3. Flashed magisk v20.1 installer via TWRP -> device starts up normally with all my data still intact and magisk + magisk manager both back to original version (magisk v20.1, magisk manager v7.4.0)
1
  • Hi, it seems you accidentally created a duplicate account. Please refer to the help center to merge your accounts and regain ownership of the question and reply to the comments on your post, including accepting an answer (comments cannot be accepted though).
    – Andrew T.
    Jan 18 at 13:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .