0
  1. I have 3 routers in the house. 2 are using bridge mode (for wi-fi coverage) and 1 main router
  2. My other devices work fine (either connect to the main router or bridge mode routers)
  3. All routers use the same wi-fi identifier
  4. When I move my phone closer to the main router, it works fine
  5. When I change my IP to static instead of DHCP and keep everything else the same, it says connected, but actually no internet
  6. My phone can always access the router's UI. And in the GUI I can see my phone is connected to it even though it's the only one that can't access the internet
  7. I have tried restarting the phone
  8. I have tried "forget network" and reconnect
  9. No proxy used

I generally don't like to use static IP as it can create conflicts. It is so strange so please help me! My android version is 8.0.0

1
  • Is the gateway IP correctly set when you are connected to the different Wifi networks? Check it in Wifi settings when you are connected.
    – Robert
    Jan 12 at 14:41

1 Answer 1

0

Ok, I have tried switch mode with access point, same results. I disabled IPv6 option in the secondary router and it works. I guess android 8.0.0 doesn't support IPv6. Not sure why the router still honors IPv6 since it's in bridge mode or switch mode.

Again other devices always work. My assumption is this android somehow honors the IPv6 option in the secondary router even though the router is not in router mode.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .