1

I search hours on internet but didn't find solution.

I install Android x86 and Android Phoenix OS on VMware Workstation. Both Freezing in x86_64:/ # and Android doesn't come up But I Found Solution and it's Work. editt kernel and add this "nomodeset xforcevesa"

Now Problem is: in Android x86 in grub menu it has debug mode and I can choose it and go through editing But in Android Phoenix OS there is no debug mode in menu. So How I Access to Debug mode in Phoenix OS? is has any command that i use in CLT to run debug mode?

Please see the images below: enter image description here

enter image description here

4
  • 1
    As the text in the lower part of each screen indicates pressing e should give you the possibility to edit the boot command line of the kernel. So you should be able to show the command used by Android x86 in debug mode.
    – Robert
    Jan 14 at 2:51
  • forcing vesa vga drivers is no solution it's just emergency workaround
    – alecxs
    Jan 14 at 10:39
  • I found only this solution on the internet and its working, better as nothing. and pressing "e", I know that, but it's edit kernel temporary and I should do it every time but as you can see in second image, we have debug mode option that I can choose it, that in there we can edit kernel permanently with some codes. I can press "C" and go to CLT but I don't know how access to debug mode. Does it have a code to go to debug mode? Jan 15 at 0:53
  • I think your question is about configuring grub forum.xda-developers.com/showthread.php?t=3684456
    – alecxs
    Jan 15 at 9:16
0

I didn't find a solution to how to go to the debug mode. but I find the solution to my problem that now I can edit kernel directly.

in the setup section of phoenix os choose the second option then press tab and now edit where you want to edit

enter image description here enter image description here

1
  • an alternative way is to open iso of phoenix os and open efi folder then boot folder and then open grub.cfg file with notepad and edit where you want to edit Jan 16 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.