0

Google Assistant crashes the moment I open the app. Due to this. I'm unable to invoke my Assistant even though having setup all it's settings such as turning it On, setting up 'Hey Google' and training the voice recognition model. Similarly, The Google App crashes the moment I try voice search.(Open 'Google' App, click on the 'Mic' icon on the search bar for voice input to search.)

I tried few fixes after searching online and troubleshooting guides from google, but nothing seemed to work even after enabling all the options mentioned in those guides.

I need this community's help in figuring out what's causing this and fixing it. Can anyone help me on this please?

Phone: Oneplus 6. (I've used google assistant a couple of years ago, but never used in the past 2+ yrs. Now that I've got a few smart devices, I want to use it again.) OS: Oxygen OS 9.0.9

Edit: I have tried a fix that I found online, which was clearing the data of 'Google' app and restarting the phone. But the situation ended up being worse than before. Now, when I go to the 'Hey Google & Voice Match' setting, I see 'An Error has occurred. Please try again later.'(Attached an image below).
Error at 'Hey Google' settings.

Cheers!

2
  • Is it possible for you to reset your phone? Since it is an old phone, a lot of things might have broken. Commented Jan 24, 2022 at 7:19
  • I'm not considering this option at the moment, due to the mess of setting up everything on the phone post resetting. Commented Jan 25, 2022 at 14:07

1 Answer 1

0

I have faced the same issue and fixed it too. In settings, search "default", and then select Google assistant as the default assistant app

3
  • Hi, thanks for this reply. I'm not getting any search results pertaining to default assistant in my settings. Commented Jan 25, 2022 at 14:04
  • @PraveenSamudrala you sure your google app has microphone permission enabled? Commented Jan 25, 2022 at 17:15
  • Hey, all the required permissions for Google app are enabled. Commented Jan 25, 2022 at 23:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .