0

Today, after trying to go back from RevengeOS to MIUI, I used TWRP to wipe System, Data, Internal Storage, Vendor, and Dalvik/ART + cache, then flashed stock MIUI, forgetting that it has problems, and it needs to be flashed through PC with those 6GB stock images.

So I'm stuck in a boot loop. Nothing special except for the fact that when I try to connect the phone to the laptop and reflash the correct thing through fastboot, the phone is not visible to fastboot (waiting for any device), and the laptop itself is making a constant USB-disconnect sound around 10-15 seconds repeatedly.

Is there any way to fix this without having to send it to the repair services, or throwing away the phone? I am unable to boot into recovery with Power + Vol+, nor use the fastboot, nor boot into the system and use adc from there (obviously).

Sometimes it goes from fastboot to boot looping again on itself but 1 time it seemed to die, so I waited for an hour, and then tried. Nothing changed. Everything about SDK tools is fine on my PC, as I am not a newbie in flashing - given that I have been doing that for around 3 years now.

1
  • If I am not mistaken your device has a Mediatek CPU. Often Mediatek devices can be flashed in off state using special tools like MTK Flash Tool. This could be worth a try if these tools recognize your phone at all.
    – Robert
    Jan 24 at 14:05

1 Answer 1

0

From the 2nd revision of OP's question,

Fixed by downloading second latest miflash version (the last one that needs to be installed, not just unzipped) stopped the disconnecting, and allowed to use flash_all.bat (I'm confused)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .