3

I have an Android Galaxy S2, running CyanogenMod 7. I was normally using my phone, in a middle of using Waze while driving when suddenly I started getting 'Force Close' messages like this:

Sorry!
The process com.android.phone has stopped unexpectedly. Please try again.

I get bombarded by these messages, for lots of different processes like com.android.phone, android.process.com.acore. If I try to run an app (in the milliseconds of intervals between these messages), they usually close immediately with their processes generating more 'Force Close' messages.
In addition, the phone has no signal at all.

Tried to find solutions online, but couldn't come up with anything other than trying to remove my SD Card, but that didn't help. Resetting obviously didn't help. I would appreciate any suggestion you can offer.

  • why are you still using CM7? CM9 has been stable for ages now. – warsong Jun 21 '12 at 17:46
2

Your mention of 'reset' is a little unclear, if it's:

  • You did a reboot and it's still broken:
    it might be broken settings, but that's not easy to debug and fix manually
    BACKUP via recovery first!
    Do a Wipe Dalvik Cache via Recovery
    Else, reinstall your current ROM & Google Apps, maybe this helps
    See what adb logcat outputs during boot/runtime, maybe this sheds some light
    (hacky, via adb shell) You can also forcibly rename /system/app/Phone.apk to Phone.apk.off and reboot, then do a backup of all needed stuff and then reinstall your rom & GApps
    If all that doesn't help, consider wiping.
    Titanium Backup Pro allows extracting backups from your saved Nandroid dump (from step 1)

  • Fully wiped and still not better:
    has to be something different than settings, either a faulty Rom or a hardware issue
    BACKUP via recovery first!
    Install CM7.2 (see last sentence), wipe cache & dalvik cache via recovery

PS: CM7.2 is out since June 16, 2012.

  • Wiping caches is completely useless. Renaming the phone app can cause FC too. – R R Jun 20 '12 at 20:58
  • Yes, renaming will cause that, but my recipe here 'to just use the phone to do a ti backup' is to render that apk inaccessible for the next boot (renaming does the job here). No FC's will happen from this the next start and you can calmly do all ti backup stuff that's needed – ce4 Jun 20 '12 at 21:03
  • Ended up wiping and installing CM9. – Amir Rachum Jun 22 '12 at 9:57
0

mine was simple (droid razr), i unistalled root tools and i had a pulldown banner. i reinstalled root tools and redid my bannerand its fine now

  • 2
    Given that the OP didn't mention any of this, it seems extremely unlikely that his issue and yours are related. Processes can crash for lots of reasons. – Matthew Read Jun 21 '12 at 17:54
  • true mine was same problem just the file wasnt present, thanks tho – bryan Jun 21 '12 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.