I know I know: Again someone asking "how do I unlock my phone without the pattern", but please read to the end haha.

I use a VPN software on my phone that asks me to change me lock screen settings every 6 months. So did I, guess what, 6 months ago. Since I never restarted my phone and I use face unlock and fingerprint, I never had to re-enter my pattern. Today I was stupid enough to restart my phone and locked myself out.

It's a huawei mate 10 pro (BLA-29) and yes, I can prove that I am the legal owner of this device :D

Some months ago I activated the developer options and also USB debugging. Why? I thought that I could remove the "gesture.key" file if I forget the pattern. So yes, my PC can find the phone with fastboot and abd. But i did NOT unlock the boot loader (and I did not check the option in the developer settings).

I tested a lot of patterns but the time inbetween the 3 chances to enter a pattern rises, I am at 2 hours at the moment.

Fortunatelly I added a second user account to the phone, but it's a standard user and not an admin. I also installed "lostandroid" by https://www.androidlost.com/ but unfortunatelly my phone does not receive any commands since I am logged in with the second (non-admin) account.

My next attempt was to remove the pattern file via "adb shell rm /data/system/gesture.key" but the file does not exists. Yes, I googled and found out, that since android marshmellow the files are p.e. "/data/system/gatekeeper.pattern.key" but this file ALSO does not exist.

  • I can't flash a new zip or su.zip since the bootloader is still locked and I can't unlock it.
  • I can't pull the gesture file since none of them (as mentioned above) exist.
  • I can't push another key since I always get "permission denied", no matter to which directory I try to push
  • "SU" is not installed.
  • "adb root" doesn't to anything but also throws no error.
  • The system partition is read only.
  • I can't remount the system partition since it gives a error message that verity is enabled.
  • I can't disable verity since it's a user build.
  • The backup created with "adb backup" are way too small (just about 1 GB), no matter which parameters (apk/noapk, all, system/nosystem etc.) I use. So there is no chance to create a backup of my data, right?
  • I can't unlock the bootloader with "fastboot oem unlock UUUUUUUUUUUUUUUU" since I did not check the setting in the developer options. My second user is not allowed to open the developer settings.
  • my second account seems to be broken since my phone throws an error "apps are beeing prepare, try again later" (translated roughly from German) but even after 2 hours, several reboots, the apps don't open.

I stumbled accross this thread and honestly I dont know if this could help with my problem.

How to disable dm-verity on Android with "user" build type ROM?

So is there anybody that can help me with this? I know that I am really stupid but hard resetting without a backup is no option. I got backup files of course but I received important files of a big customer of my business on that phone 2 days ago, so there is no backup yet which includes these files.

As I wrote: it's my phone, I can prove it :D but it's really important so maybe there is anybody that can help me :(

  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Andrew T.
    Feb 2, 2022 at 20:48

1 Answer 1


Success. Even if I can't explain how/why. I took my phone and my muscle memory "remembered" the correct pattern. At first I was happy with that, of course, but then I realized that it was the pattern that I tried a dozen times in the last 2 days. I also wrote down all patterns that I tried and it was the very first!

How come it suddenly worked? Now knowing the pattern I locked my phone again and unlo... wait. I was in. No pattern any more. it just disappeared!

I opened the settings app and searched for the security settings for "display lock". Before, I could decide between "PIN" (numbers only), "Password" (alphanumeric) and pattern. "Face unlock" and "fingerprint" were additionally available AFTER I set up a display lock.

But now I can only choose "unlock password" which is a fixed length (6 digit) number. Why do they call it "password" if it's just a PIN?!

So... why are the other options gone? Why can't I choose the pattern anymore? Why did it suddenly disappear? Questions after questions.

My system information tell me that the phone still runs with android 10 and EMUI 10, the last security patch was on "01.07.2021" (july 1st). Also "USB debugging" was disabled. There was no software update for a long time.

I am glad that I can use my phone again but I felt like the dumbest person on earth since I own a repair shop and I repair smartphones since 2010. Every time a customer tells me that he did not make any backups (what I did!) and that he did not set up any recovery option for his phone, I get a little angry with him.

And then I could not access my own phone even I set up

  • huawei ID
  • google "find my phone"
  • "Lost android" by www.androidlost.com
  • SMS commands (like unlocking my fckn phone!) by www.androidlost.com
  • USB debugging with an authorization for my computer but nothing of that worked.

In conclusion: I may not be as stupid as I felt and I'll never get an answer on how that happened. But I'm very happy.

thanks for your time @alecxs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .