0

I tried everything from every tutorial about how to unlock my Xiaomi Poco M3 bootloader. I enabled OEM unlock, etc, rebooted into fastboot mode, but then the phone is not recognized in the batch unlock tool provided by xiaomi at https://en.miui.com/unlock/download_en.html

Well, I found https://developer.android.com/studio/run/oem-usb where it lists this weird forum https://web.vip.miui.com/page/info/mio/mio/detail?postId=18464849&app_version=dev.20051 for the xiaomi, which contains a .rar file that when I install I get

enter image description here

because the driver is not signed. I don't think I should disable driver signing on Windows, and I find this very weird.

I also tried installing Android Studio and then google USB drivers through there, but I still don´t get the phone recognized on the miui unlock tool.

2
  • The ADB driver is always the same for every device but Windows does not know that so you have to select the driver manually. Use the original from Google developer.android.com/studio/run/win-usb and select it manually in the driver install dialog. But something is weird: you want to use fastboot but the dialog shows adb USB device. ADB and fastboot require different drivers and are never active at same time.
    – Robert
    Commented Feb 16, 2022 at 20:34
  • @Robert I downloaded the zip from this page and tried to add manually in device manager for my Android but it dit not work, I don't remember why. Take a look on my new answer, it's what worked. I also don't know why it says adb. I want to unlock the device. Commented Feb 16, 2022 at 20:47

1 Answer 1

0

I don't know if the solution posted by Robert works but I downloaded an older MiUi Unlock tool that is listed here: https://c.mi.com/thread-2262302-1-0.html. I tried this one http://miuirom.xiaomi.com/rom/u1106245679/4.5.514.47/miflash_unlock-en-4.5.514.47.zip and it has an option (in the gear settings icon) to install the drivers. I clicked on it, installed the drivers, and then gone back to the latest version of the unlock tool, and it recognized the phone!

PS: if this does not work try updating the MiUi to the latest one, and also try to do as Robert said. I think the link he gave is for download the driver, but then you have to do into Device Manager, find your android device and install the driver for it. This step failed for me but anyways, worth a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .