I've acquired a Lenovo Yoga Book (YB1-X90F) that doesn't boot into the OS. I can access the bootloader and recovery environment.

I've followed the guide over at XDA that uses Intel Platform Flash Tool, but I get errors straight away. Another person has the same problem--2nd to last poster.:

02/20/22 15:54:20.155  ERROR  : [Port 1/7] Command `"C:\Program Files (x86)\Intel\Platform Flash Tool Lite\fastboot.exe" "-s"
"YETIDD2E4EC8" "flashing" "unlock"` failed
02/20/22 15:54:20.155  ERROR  : [Port 1/7] Flash failed (Command type: Fastboot)

I've also installed Minimal ADB and Fastboot but I don't know what I'm doing.

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot devices
YETIDD2E4EC8    fastboot

C:\Program Files (x86)\Minimal ADB and Fastboot>adb devices List of
devices attached

C:\Program Files (x86)\Minimal ADB and Fastboot>

The ROM I got (YB1-X90F_USR_S000196_1611040312_WW06_BP_ROW-flashfiles.zip) from some random site includes what looks like some info or installation steps in the .zip, but even with Word auto-translation into Chinglish, I don't understand what is being said.

Original: https://docs.google.com/document/d/1oSLs0o5x1UMwNULU33W8f150-CXcP8a0/edit?usp=sharing&ouid=105608869882772012095&rtpof=true&sd=true

Translated: https://docs.google.com/document/d/1rspmYkqhzcx0Muu3QoFPmjWz9mRsO6CE/edit?usp=sharing&ouid=105608869882772012095&rtpof=true&sd=true

Any input would be greatly appreciated.

  • What happens if you select "Wide data" or "Wipe cache" in recovery?
    – Robert
    Feb 20, 2022 at 16:51
  • Thanks for the response. Sorry, forgot to mention that. It completes the wipes but doesn't do anything to solve the issue.
    – Paft
    Feb 20, 2022 at 16:59

1 Answer 1


Solved. I ran 'flash_update_from_user.json

Just waiting for the battery to charge to 30% to hopefully enable the Halo Keyboard.

Here are the files needed in case other links void in the future: https://drive.google.com/drive/folders/1gD9FyA03GbLZ7ZcjkyMDlhVPs4_em2rY?usp=sharing

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .