1

I'm trying to update an app on a smartwatch, but whatever I try, I ran into errors.

  1. adb install newversion.apk => [INSTALL_FAILED_VERSION_DOWNGRADE]

  2. adb install -r -d newversion.apk => [INSTALL_FAILED_UPDATE_INCOMPATIBLE]

  3. adb uninstall {packagename} => Failure [DELETE_FAILED_INTERNAL_ERROR]

4a) adb shell pm uninstall --user 0 {packagename} => success

4b) adb install newversion.apk => [INSTALL_FAILED_VERSION_DOWNGRADE]

App is a launcher. OS has no launcher now. I still cannot install my new version.

Checking for other users: pm list users -> users: UserInfo{0:Owner:13} running.

So I'm the only user. Also tried the uninstall --user command with other user IDs like 0, 1, 10-15, 2000+, 300+, all nothing.

I am not rooted. su does not work. It's an MT6739 chipset with Android 7.1.1 running.

Nothing that I try lets me install my new app. Also not after factory reset.

6
  • I would assume that you are trying to install an app that sues a package name already used by a system app on that device but your app has a different signature and thus can't be installed as update. I would recommend to repackage the app e.g. apktool decompile, modify app name, recompile, resign) and then install it using a different package name to avoid those problems.
    – Robert
    Feb 24, 2022 at 15:18
  • Not possible. The old app on the system is the problem. new app should not be changed.
    – Hasse
    Feb 24, 2022 at 15:32
  • Then you have to identify the APK on system partition and delete it.
    – Robert
    Feb 24, 2022 at 16:20
  • But that requires root rights I believe? I dont have root....
    – Hasse
    Feb 25, 2022 at 8:02
  • Sorry I misread what you wrote about root. Usually people don't mention su if their device is not rooted. Then you only have the option to modify the APK that should be installed.
    – Robert
    Feb 25, 2022 at 8:04

0

You must log in to answer this question.

Browse other questions tagged .