0

I'm trying to run com.google.android.setupwizard/.SetupWizardTestActivity as a solution to the following...

Moto C Plus phone suddenly turns off while in pocket. Turned it on. Turns back off. Plugged it to charger. Battery at %17...hmmm weird.

Phone turns on but now I see...

  1. The icon size went to default from the small that I'd set it at. The screen time out went to 30 secs from the 2 mins it was set to.

  2. The keyboard went to the phone's default keyboard from the one I'd installed.

  3. The home and recent buttons - although they are registering the touch - are not doing anything when I press them.

  4. The back button is working and is now the only way I can exit the current screen.

  5. The screen lock pattern doesn't come on.

  6. The notification bar cannot fully be pulled down.

  7. The developer option now says "Developer options are not available for this user". Pressing Build 7 times doesn't activate it.

I came across this (first answer) as a solution in a couple of places. The solution they say is to basically run com.google.android.setupwizard/.SetupWizardTestActivity through NovaLauncher. But the problem is, I'm not seeing SetupWizardTestActivity where it's supposed to be. I'm guessing perhaps it's because I'm rooted?

So now I'm looking for another way to run it from the phone (because I can't connect the phone to a computer because the data pins in the charger port are missing from a botched charger port replacement job).

I came across this as a way to run SetupWizardTestActivity without NovaLauncher. It's...

  1. adb shell su pm enable com.google.android.setupwizard/com.google.android.setupwizard.SetupWizardActivity
  1. adb shell settings put secure user_setup_complete 0

The first command is case sensitive (SetupWizardActivity)

However, I'm not sure if the above is to be done through a computer or on the phone. If it's through the phone then i need a little help as how to exactly do it.

I'd REALLY appreciate if anyone can guide me through this in layman's terms. A simple step by step on how to go about accomplishing this would be hugely appreciated. Emphasis on "layman's"

Thanks in advance!

2
  • As you are facing so many changes is strange. Who knows what other changes were made you don't recognize? Therefore I would strongly recommend to perform a factory reset. If the problems persists you know that something is wrong with the OS itself (so it may be wise to reset the device completely using "Rescue and Smart Assistant").
    – Robert
    Commented Feb 26, 2022 at 18:06
  • I'm trying to run com.google.android.setupwizard/.SetupWizardTestActivity
    – JJrussel
    Commented Feb 26, 2022 at 18:33

1 Answer 1

0

Figured it out!

I wasn't able to do it through Nova Launcher as described here (because I don't see SetupWizardTestActivity on my phone, like you can see here).

So I found another app where I could - Activity Launcher.

Here's what you do...

  1. Download and install Activity Launcher on your phone. You most probably won't be able to do so through Play Store because your phone won't allow you in the state that it's in. It'll just say pending when you click install. So what you'd have to do is download the apk and install it that way. A trusted website for downloading apks is apkmirror.com.

How to download...

Step 1:

Go here

Step 2:

enter image description here

Step 3:

enter image description here

Step 4:

enter image description here

Step 5:

Step 6: enter image description here

Step 7: enter image description here

Note: The latest version you see now might be different than the one posted above.

  1. Install it. Pretty simple. Just follow the instructions.

  2. Launch the app. .

  3. Scroll down and find Setup Wizard. Tap on (select) it (not the dots next to it). enter image description here

  4. Select the three dots next to com.google.android.setupwizard/.SetupWizardTestActivity. Alternatively you could long press it to get the same result (which is to see the menus in step 6 below). enter image description here

  5. Select "Launch activity as root" (needless to say, your phone has to be rooted to select this option. I have no idea if it works without root. You could select this option if you're not rooted and let us know how it goes). enter image description here

  6. If you have SuperSU (or other variations) installed, grant (root) access. enter image description here

  7. A screen like this will pop up: enter image description here

  8. Select GET STARTED.

  9. Follow the prompts.

It will ask you if you want to restore your account or create a new one. I'm assuming you're reading this guide because you want to restore your account so select "Keeps your apps & data). enter image description here

It will want to connect to the internet to set up your account. If it takes a long time, click back and opt to proceed without pulling up your account. You'll get a prompt asking if you're sure, say yes and Viola! Everything will be the way it was before the problem started. You might have to renter your wifi password and change back your keyboard and some personal customizations that went back to default, but nothing major. Everything will be there the way you left it, even your recent and browser tabs.

3
  • Why this long explanation how to download an APK from apkmirror.com if you can simply get if from Google Play Store play.google.com/store/apps/… IMHO for Apkmirror.com the link to the app would have been sufficient.
    – Robert
    Commented Feb 27, 2022 at 11:19
  • Thanks for your valuable contribution. Your solution to factory reset was steller!
    – JJrussel
    Commented Feb 27, 2022 at 11:44
  • Sorry but I don't know what "steller" means, no dictionary I checked knows this word. If it worked without factory reset for you good, I hope for you that there aren't any important options changed that don't have an UI.
    – Robert
    Commented Feb 27, 2022 at 11:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .