Often I can't see any files in DCIM\Camera on my Galaxy S21 Ultra running Android 12. Last night it worked and I copied multiple GB of videos / images, then it didn't work the next times I tried.

I've tried the following steps:

  • Rebooting phone and computer
  • Uninstalling the phone in Device Manager under Portable Devices
  • Updating the USB driver using the ... menu in Smart Switch
  • Updating the USB driver by downloading directly from Samsung
  • Enabling USB Debugging mode and rebooting (this made things worse so I had to turn it off)
  • Changing the USB mode to charge only and then back to "USB for file transfer"
  • Changing the USB mode to "USB for image transfer"

Any ideas on how to fix this?

1 Answer 1


This was able to be solved using the Files app to move a bunch of images to another folder and move those off the device and then the DCIM\Camera folder worked again (read online that the image count can be a cause of this issue).

As a tip, pressing and holding and dragging allows selecting a bunch of files relatively easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .