1

I need to limit cellular speeds in Android Studio's Emulator. I tried to limit it from the default settings:

but it does not work. Each time I select anything lower than LTE I get like 0.01Mbps.

Any idea how to fix it so I get the speeds which are described in reference:

                  UP(KBps) DOWN (KBps)
                  -------- ----------
gsm   GSM/CSD         14.4       14.4
hscsd HSCSD           14.4       57.6
gprs  GPRS            28.8       57.6
umts  UMTS/3G        384.0      384.0
edge  EDGE/EGPRS     473.6      473.6
hsdpa HSDPA         5760.0   13,980.0
lte   LTE         58,000.0  173,000.0
evdo  EVDO        75,000.0  280,000.0
full  No limit           ∞          ∞
2
  • Are you sure the network type settings also affects the network bandwidth? In reality the limitation is of technical nature and thus coupled. But on the emulator I would suspect that there are two independent settings (allows more test scenarios). I would try to start the emulator using command emulator -netspeed gsm to check if the simulated network speed is working properly.
    – Robert
    Commented Feb 28, 2022 at 12:42
  • @Robert Still same
    – Baterka
    Commented Feb 28, 2022 at 13:12

1 Answer 1

0

I have the same issue, either the speed is really fast or so slow that it basically is not working at all. I also tried using "adb emu network speed 4096" in the terminal for multiple speeds, the results are the same. My solution was to install clumsy. With clumsy, you can simulate a slow internet connection on your PC and with it on your emulator as well.

PS. I had a problem with clumsy as well, it didn't work, but when I set the filtering to "outbound" it started working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .