I can not turn on my android device Wifi. It shows error. My device is Huawei U8500. I am using CyanogenMod 7.2.0 Update-6. Please help with this?

  • 2
    What's the error? You've used the cyanogenmod tag. Does that mean you're rooted and using a custom ROM? – ale Jun 21 '12 at 19:53
  • Yes. My phone is already rooted.Still i am suffering with my wifi. How can I solve it. It shows error .. nothing else. I am using custom rom . Android version 2.3.7 – BABU Jun 22 '12 at 11:05
  • 1
    What is the error message? Can you provide more details? You currently to vague on your information to help you – Flow Jun 22 '12 at 13:41

You phone, Huawei U8500 may have the boot kernel and the system modules with different versions.

Since you aren't providing the error message contents, I'll assume that you're just getting a plain wifi error notice instead of the usual wifi connecting to...

Generally speaking,

The kernel (which is on boot.img) must match the WiFi modules version (which is on system) if not, WiFi cant be loaded.

What you need to do is:

Install 7.2 and flash the boot separately, so the boot kernel and the system modules can obtain the same version.

A similar case:

You can read about a similar case in detail at:

To summarize it:

A user performed an update to the system version 7.2, but didn't flash the boot to the same version.

Every time the user tried to use WiFi, the message wifi error was presented.

If he rolled-back to the previous version, the WiFi worked just fine.

After some discussion and exchanging of ideas, he came up with a solution:

Resolved. Here is the clear solution (not completely clear earlier).

  1. Install CM 7.2 OTA when prompted
  2. DO not roll back to 7.1
  3. THEN extract boot.img from the cm 7.2 zip, reboot the phone to bootloader, fastboot flash boot boot.img using PC

So what was happening to this case:

When the user had 7.1 installed and the phone had:

  • boot - 7.1 kernel
  • system - 7.1 modules

After the installation of 7.2, the phone had:

  • boot - 7.1 kernel
  • system - 7.2 modules

When re-installed 7.1, the phone had:

  • boot - 7.1 kernel
  • system - 7.1 modules

so everything worked

When the user installed 7.2 and flashed the boot separately the phone had:

  • boot - 7.2 kernel
  • system - 7.2 modules

and everything worked

Related reading:

  • Sounds useful but I have no idea what to do. Can somebody write that in plain language with nice little pictures for those of us who don't live in the world of system names and numbers? – user31773 Apr 6 '13 at 18:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.