I have a rooted Android 11.

Using Termux, or Es File Explorer, I can see all the 284 directories in /data/data.

Unfortunately, many file explorer apps (with root privileges, such as Total Commander, ZArchiver) can only see 2 folders : com.google.android.gms (don't know why), and their own data folder.

I thought this was related to this, but apparently no since I granted the root privileges to both apps...

How could I see all the folders in /data/data using (for example) Total Commander? Doing a chmod 755 in Termux? Or maybe there is a problem with these apps as if they they don't use root privileges if at least one folder/file is visible in "normal user" mode?

  • How do you grant root access to Total Commander / ZArchiver? It works fine Android 10
    – alecxs
    Mar 6, 2022 at 1:11
  • 1
    In their settings, I selected to read files/folders as root (a pop-up from Magisk asking me if I want to grant - or not - root privileges). They also have a setting "Fix SELinux Context" checked by default, but unchecking this does not seem to solve the issue. Mar 6, 2022 at 8:19
  • 1
    guess it's related to mount namespaces, the apps does not handle it well. you can set to global in magisk settings for testing purposes
    – alecxs
    Mar 6, 2022 at 10:55
  • @alecxs thanks! Did not know about this option (I think the problem of not be able to see folders in /data/data is due to an update of magisk - changing some settings). Just tried and it works just as I wanted ! Please consider to write an answer to get more reputation ;) Mar 7, 2022 at 11:06

1 Answer 1


To mark this question as solved.

As @alecxs said, these apps does not handle correctly mounting namespaces, and therefore we need to select in Magisk settings Mount Namespace Mode->Global Namespace instead of Inherit.

  • "By default Magisk inherits the calling process's mount namespace. This can be changed in Magisk Manager. If your root app always need global mount access, use --mount-master when calling su. This can be easily done in libsu by adding a flag in config." -- @topjohnwu on Twitter. Oct 15, 2022 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .