I have a OnePlus 7 Pro. I had LineageOS 17 (Android 10) with microG, magisk, and vanced on it running just fine for almost a year. I upgraded the Android version to 11 first (which LineageOS documentation says is a pre-requirement) then I upgraded to LineageOS 18, and everything seemed to work just fine. I can confirm that my recovery and wifi worked.

A few days later I wanted to open Vanced YT, but it was no longer installed, then I noticed that magisk was no longer installed. So I installed it according to it's instructions which was basically using the app to patch the boot.img I got from the extracted files (from a payload-dumper) and then installed the produced magisk_patched-24200_Y0Qmv.img.

Ever since then is my problem. I can no longer turn on my wifi, I no longer have recovery mode, and every time I turn on/reboot the device I am greeted with a "System UI Crashed" error message. I can hit ok and everything else seems to work as expected. With the exception to my wifi not being able to turn on

What I've tried:

  • re-flashed the original boot.img
  • re-flashed the recovery image
  • uninstalled magisk
  • I tried re-flashing other images from the payload dump (modem.img, etc) the same way the LineageOS documentation said to upgrade and I get the following error
fastboot flash --slot=all modem modem.img
fastboot: error: Could not check if partition modem has slot all

I have no idea what that error means. Nothing changed. I'm still greeted with the same crash message. I still can't turn on my wifi. And I still can't boot into recovery mode.

To make sure I'm clear, my question is; "Where should I go from here? What things can I tell you in order to help me get my wifi working again, and to fix this 'System UI Crashed' error message?"

1 Answer 1


So I figured out what I did wrong. I basically patched the wrong boot.img so the kernel was mismatched. I patched the one from the OnePlus OxygenOS. Instead I needed to patch the one from LineageOS.

The steps I took in order to fix it was:

  1. unzip the LineageOS zip
  2. extract the payload with a payload dumper
  3. copy the boot.img to my device
  4. patch that boot.img
  5. copy the magisk patched image which was produced from the magisk app to my computer with adb and fastboot on it
  6. booted my android device into fastboot mode
  7. flashed that magisk patched boot image to my device

After that when it rebooted, everything worked as expected with one exception; GCam. But I think this is related to the LinageOS upgrade. I was able to fix this by re-installing microG and upgrading to a newer version of GCam. All other original issues where cleared though. Wifi, phone, etc.

I hope this helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .