I have a rooted Oneplus 7 Pro. Today my phone said that an OTA had finished downloading and to reboot to install the update. I had been postponing this update and decided to finally go through with it.

I went through all the steps to keep my root, uninstall magisk, download OTA, flash twrp ab retension script, install magisk to inactive slot, and finally reboot. I am now stuck at the boot animation.

When I try to boot into TWRP, the screen keeps flashing at the TWRP loading screen but I can never actually get into it. I am able to ADB into the phone at this point though and the recovery.log says something about Fatal signal 6 (SIGABRT), code -6 (SI_TKILL) Does anyone know know how to fix this? Any help would be greatly appreciated!

Edit: I have made a little progress. I was able to change the partition back to the original partition and while I still can't boot, I can get into TWRP now.

Edit2: I updated my TWRP and can now get into TWRP on both partitions. On the old partition I can decrypt my data with pattern (and was able to back everything up), but on the new partition it is asking for a password and I don't have one. Still get stuck on the boot animation are both partitions. I have also tried uninstalling all my magisk modules (except for one adb one) and that didn't help either.

1 Answer 1


If you are someway able to boot into fastboot, try flashing stock boot.img there (Google might help you in finding stock imgs).

Otherwise, get the firmware flashing tools for OnePlus and reinstall stock from scratch which but would erase userdata though.

  • Thanks for the response. Sadly it didn't work. On the old partition it got stuck at the boot animation. On the new partition I got a qualcomm crashdump mode attempted to kill init! exitcode=0x00007f00. On the old partition the boot animation did seem to be running more smoothly though, so that's a plus!
    – Winnie22
    Mar 16, 2022 at 17:45
  • @Winnie22 in that case I'm really sorry brother.. I would have personally helped you out if I owned a OnePlus Mar 16, 2022 at 19:00
  • That actually was the answer! The only issue was I was on OOS Beta so the stock boot.img didn't work and I think the update wasn't for the latest version so the latest beta boot.img didn't work. I used ADB to pull the update zip from my phone, used payload-dumper to extract the boot.img and that booted me right into the phone! Thank you so much!
    – Winnie22
    Mar 17, 2022 at 14:56
  • if it was the answer, then upvote it bruh Mar 18, 2022 at 18:28
  • I totally would, but I don't have 15 reputation points yet....
    – Winnie22
    Mar 18, 2022 at 20:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .