1

about 2 days ago my phone completely died (battery) so i plugged it in overnight. when i tried powering it on in the morning it was getting stuck on the MIUI animation, just after the powered by android screen. after multiple attempts to restart it by long pressing the power button it entered the boot menu to try a reboot from there... no Joy. so i then tried wiping the data to see if that would help. it gets to about 3% and then the phone reboots again getting stuck in the same place.

I have tried following the instructions here but am getting

no permissions (missing udev rules? user is in the plugdev group); see [http://developer.android.com/tools/device.html] fastboot

I then tried using the Mi Unlock tool but the device is not showing up in that when I plug it in. Ive read somewhere then that i need some developer settings set in the developer options but i honestly don't remember if I ever even unlocked them on this phone as i dont do any android development any more but I may have them turned on. when the phone is plugged in i can see it in device manager as Android with a yellow warning triangle visible. I could really do, any old devices i have to tide me over have laughably short battery lifes so could really do with getting this sorted. Any help will be greatly appreciated.

NOTE I followed the above gist on my linux machiene as that is where i had the android dev stuff installed and the Mi Unlock on my windows pc which does not have any android dev tools installed

7
  • this question needs more focused to single problem. do you want to fix boot loop, factory reset device or unlock bootloader
    – alecxs
    Mar 22, 2022 at 15:44
  • @alecxs my only concern is getting my phone working again, so whatever is the easiest means to achieve that. Mar 22, 2022 at 16:15
  • check bootloader unlock is allowed fastboot flashing get_unlock_ability and unlock with XiaoMiTool v2 (linux build) or set get_unlock_ability 1 manually with edl.py (patched firehose loader and EDL cable required). or flash stock ROM on locked bootloader
    – alecxs
    Mar 22, 2022 at 17:43
  • @alecxs can you explain 'flash stock ROM on locked bootloader' I have tried installing the google ABD driver via the android studio sdk manage but this made no difference and the device is still not recognized by the miflash_unlock tool. i have been looking around a lot for miui fast boot drivers and any thing that I've found that might be useful but all I seem to find is questionable looking websites Mar 24, 2022 at 22:40
  • @alecxs when i say makes no difference, yes windows as thats where i said i had the issue with the driver (yellow triangle), yes the device is on the fastboot screen with the bunny. yes i did install the Get the Google USB Driver via android studio sdk manager as i mentioned in my last comment. fastboot flashing get_unlock_ability is returning 0. next break i get i will clean up the comments and refactor the question Mar 25, 2022 at 9:53

0

You must log in to answer this question.

Browse other questions tagged .