I saturated my phone memory, and while attempting to restart it to delete files, it got stuck on the "Mi" logo. I only have a partial backup.

Phone: Xiaomi Redmi Note 5, not rooted, not "OEM" unlocked.

What I want to do: wipe the cache (in the hopes that it will solve the problem), or if possible save the data to do a factory reset.

What I can do: I can access the Mi 3.0 recovery mode, use adb and fastboot.

What I can't do: The recovery mode doesn't offer a "wipe cache" option (only factory reset), and I can't wipe cache through adb or fastboot because the phone is not unlocked, a few examples :

adb shell su -c "rm -rf /data/data/<app's package>/cache/*"
error: closed

fastboot erase cache
******** Did you mean to fastboot format this ext4 partition?
Erasing 'cache'                                    FAILED (remote: 'Erase is not allowed in Lock State')
fastboot: error: Command failed

fastboot flash recovery twrp.img
Sending 'recovery' (35280 KB)                      OKAY [  0.856s]
Writing 'recovery'                                 FAILED (remote: 'Flashing is not allowed in Lock State')

Recovery mode also has a "pcsuite.mi.com" option, but I can't seem to make it work. I don't know how to use it, even if I have installed the Mi Suite, it doesn't detect my phone.

Do you think there is a possibility here to wipe the cache ? Or is it impossible and I must do a factory reset ?

  • @alecxs A little update: after a few manipulations (new loader because preexisting ones didn't work on Redmi Note 5, patching the driver, desactivating some windows securities) we solved a USB error 5, but still get a Sahara Error. I think I'm going to stop here, I was glad I could try this far. I am going to do a reset to factory setting. Thanks a lot for your help!
    – Agathe
    May 4, 2022 at 13:19
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Andrew T.
    Jul 8, 2022 at 13:55


You must log in to answer this question.

Browse other questions tagged .