enter image description hereI used WWR MTK Tool and SP Flash Tool v5 to dump and analyze preloader and GPT from a new Oukitel K15 Pro phone with Android 11. Oukitel haven't posted the ROM for this model for some reason. Managed to read back the ROM with SP Flash tool, but resulting partitions have weird sizes, Boot.img being only 4 MB in size, Super partition only above 512 MB in size, UserData was almost 15 GB in size. Magisk doesn't recognize extracted/dumped boot.img as a legit file, throws error. This is one weirdo ROM if those values are correct. Super partition should contain system, product, and vendor, no? How could it be so small, and not 3-4 GB? Any help appreciated. Would want to root that sucker,maybe install a GSI, but it baffles me.]2]2

  • The small boot partition is most likely not boot.img but the bootloader. Have you checked where the different partitions are mounted at run-time (if the are mounted)?
    – Robert
    Apr 21, 2022 at 20:38
  • 1
    probably your DA is not authorized so readback failed. use mtkclient
    – alecxs
    Apr 21, 2022 at 21:54

1 Answer 1


Must have been readback failure in SP Flash Tool. Thanks Alecxs for advice on using mtkclient. Worked perfectly. All partitions normal. Super is 4 GB, as expected, boot also normal. Rooting worked. Thanks for help, both of you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .