4

Possible Duplicate:
How do I sync only “My Contacts” from Google on Samsung Galaxy S?

My phone started responding really slow during sync and I suspect it has something to do with an ever-growing list of Google Contacts (nearly 2K). Is there a way to sync just some contacts? (by group or any other way) Alternatively, do you suggest I suspect anything other than my contacts' sync to do with slowing the device.

Device is HTC Legend Android 2.1

Thanks for the help!

marked as duplicate by ale, eldarerathis Jul 14 '12 at 16:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't this the slowness has anything to do with the number of contacts, but with your os version. My phone has the same hardware as yours and when I was on 2.1 syncing made the phone unusable. This was gone after updating to 2.2 And I only had ~200 contacts back than. – R R Jun 23 '12 at 9:36
4

I had the same problem often before. I never found a way.

It is possible to only SHOW a part of your contacts, but inevitably they will all get synced.

This is especially frustrating since Google automatically creates a new contact for every person on Google+ you follow and it doesn't delete it when you unfollow that person. So I got stuck with ~7k unused contacts. I have a ROMed HTC Desire and the Contacts app was taking too much memory, so I had to delete all these unused contacts myself.

But as far as I know, this option is not available, you could suggest it as a feature to Google like I did. If you ever find out how to do it, update this question please :)

  • 1
    I was in the same situation regarding G+ contacts. When I upgraded to ICS they're gone, except they still showed up on the website. – R R Jun 23 '12 at 9:33
  • You are sure they are gone? I don't see them in my Contacts either because only My Contacts are shown, but they are synced for purposes like the Gmail app auto-completion of e-mail addresses. I didn't see them but had like 40-50MB in contacts... – Steven Roose Jun 23 '12 at 9:40
  • 1
    You can switch off circle -> contacts push in g+ – ce4 Jun 23 '12 at 9:48
  • No I'm not :( No matter what I did in settings. They didn't show up (not even after enabling to show other contacts) so I checked the database, and sure enough there they are. Looks like I'm gonna have to clean them up. How did you remove them? Exported the actual contacts and deleted all? – R R Jun 23 '12 at 9:50
  • @ce4 these are the contacts that are already removed. – R R Jun 23 '12 at 9:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.