I'm very familiar with installing TWRP on a new Samsung phone. But this time it's not working, and I don't know why.

The phone is a Samsung S9+ (SM-G965F). Bootloader unlocked, data wiped and reformatted. All confirmed. Odin is working. I can flash lastest TWRP with odin, and reboot into it at first reboot. So far everything is as normal.

It should offer an option to prevent the stock rom from replacing it with the default recovery, or automatically do so. But whatever I do, it doesn't happen. First reboot to system, and I go back to default recovery. Things tried:

  • flash TWRP -> reboot directly to TWRP -> select "allow mods" -> reboot to system. (This has always been all that's needed, before now)
  • flash TWRP -> reboot directly to TWRP -> select "allow mods" -> flash multidisabler (never had to use that before) -> reboot to system

What am I missing? Why isn't it working? What else should I do?


  • TWRP < v3.6 without logical partition support is unable to mount system rw on super partition. I wonder multidisabler throw an error in recovery.log
    – alecxs
    May 1, 2022 at 20:01

1 Answer 1


What am I missing?

You probably took a gap modding Android and meantime lot of things changed

Why isn't it working?

I dont remember since when was this implemented, but since a few years (1-3), stock ROMs replace custom recovery

What else should I do?

Try (any of the first 3) at your own risk

  1. I have heard that deleting /system/recovery-from-boot.p helps but haven't tried myself so can't guarantee anything

  2. I am aware of a magisk module that keeps twrp installed even after reboot, maybe try Googling to find it.

  3. Maybe install a GSI or a custom ROM instead of stock, since they don't replace custom recoveries

  4. Give up

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .