0

I have a Raspberry Pi 3 Model B Plus Rev 1.3 with Kali 2021.2 running on it. This RPi works as a little server which I SSH to. The RPi is connected via USB to an Android 8.1 device, so I can SSH to the RPi and use ADB to manage the Android device.

This all worked fine with my previous Raspberry Pi (I don't remember which model it was). With the current one, I can use some ADB commands, and I can log into ADB shell to browse the filesystem or run some commands from it.

The problem is that when I transfer a certain amount of data, the ADB connection crashes. When I want the ADB to reconnect, I need to go to the Android device and confirm on its screen that I want to enable USB debugging from the RPi (the classic prompt which shows the first time you connect to an Android device via ADB).

I don't know the exact size limit when the crash happens, but I think its just a few megabytes, maybe even less. It happened to me when I attempted to install an APK (a small ~7 MB one), to push a file onto the SD card, or to pull a file from the device. It also happens when I run adb shell cat file on a bigger text file, or even when I run adb logcat without filters after a few days the device has been up.

I can perform any ADB command without any problem when I connect the USB cable directly from my laptop.

The ADB version in adb --help is Android Debug Bridge version 1.0.41, Version 28.0.2-debian if that is relevant, but my guess is that the problem would have something to do with the USB bus of the RPi.

Did anyone encounter this problem before? How can I make the ADB on the RPi work?

1

0

You must log in to answer this question.

Browse other questions tagged .