I have flashed a lineage OS 18.1 custom ROM on my Samsung A30 device. I am able to boot into the system successfully. However, I am facing issues while flashing Open Gapps. I have followed below steps:

  1. Flashed Lineage OS 18.1 (lineage-18.1-20220414-UNOFFICIAL-arm64_bvS.img.xz) using TWRP recovery. (selected System Image)
  2. Booted into the system.
  3. Enabled 'USB Debugging' in developer options.
  4. Turned off the device.
  5. Booted into Recovery mode (TWRP)
  6. Install > Install Zip > OpenGapps.zip
  7. Got the error code 70 (insufficient space)
  8. Again went back to home screen of TWRP
  9. Wipe > Selected 'System' > Advanced Wipe > Resize File System.
  10. Got this error - /sbin/e2fsck -fp /dev/block/mmcblk0p25 process ended with ERROR: 4 Unable to repair system
  11. Tried changing file system of 'System' to EXT2 and then back EXT4. [I am little bit skeptical of this step, since I feel this would wipe out the entire partition (owing to my experience in installing Arch Linux, where the user should format a file in ext4 partition for /home). Nevertheless, I followed this because it was mentioned in of the forums]
  12. Boot into system. Now the device is stuck in boot loop.

I am not quite sure, where I am going wrong. I am using TWRP 3.3.1-0. Any help is greatly appreciated.

  • 1
    AFAIK, flashing Gapps should be done before the first boot. This is mentioned for all devices in the official LineageOS wiki: "NOTE: If you want the Google Apps add-on on your device, you must follow this step before booting into LineageOS for the first time!" Also, which OpenGapps flavor did you choose? /system partition usually doesn't have enough space, so only nano or pico is flashable (e.g. forum.xda-developers.com/t/…)
    – Andrew T.
    May 11, 2022 at 9:35
  • Though, looks like there are actually 2 questions here? (1) how to flash Gapps on LineageOS (the title), and (2) how to get my device unstuck from the boot loop (the body)
    – Andrew T.
    May 11, 2022 at 9:45
  • @AndrewT. , I am using pico flavor. And, I even tried flashing Open Gapps immediately after lineage OS installation. It throws same error - less space available. My only question is how to flash Gapps on Lineage OS
    – DaSnipeKid
    May 11, 2022 at 11:59
  • Any catch on this ? I seriously need the GApps on lineage OS
    – DaSnipeKid
    May 11, 2022 at 22:30
  • 1
    @alecxs You can get the recovery log here : pastebin.com/8BR77aNv
    – DaSnipeKid
    May 21, 2022 at 19:20

1 Answer 1


there is enough size on partition 4800MB just the file system 1907MB is not using half of it. can be fixed with resize2fs

resize2fs /dev/block/mmcblk0p25 1171875
  • I tried resizing in TWRP terminal. It resized, but the new size is 63MB, which is still insufficient for the Gapps
    – DaSnipeKid
    May 22, 2022 at 13:40
  • assuming 4k blocks specifying size 1171875 as additional argument will increase to 4800MB
    – alecxs
    May 28, 2022 at 19:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .