1

I used Google Maps navigation for times without any problem, on several different devices; currently I'm using a Google Pixel 3a, and it first worked properly too.

But suddenly, it began to cut EACH guidance phrase before the end, like in this example (freely translated from French):

In 200 meters, at the roundabout, take the (silent here)

This happened systematically during some days, after which it started working properly again.
But it started again cutting phrases some other days later!

This has occurred during months: working - not working - working - not working...
Till it totally stopped talking: visually the navigation process works fine, but now the device never says anything at all.

Obviously I controlled my configuration, which is correctly set to have the guidance playing.

Important precision: very strangely, this happens for car guidance, but pedestrian one talks normally!

I tried following numerous help pages from the net, without success: they all address either configuration settings or device malfunction, so the proposed solution always concerns a general problem (affecting any sound usage, at least inside of Google Maps), while my problem clearly happens for only certain parts.

1 Answer 1

0

TL;DR

Depending on which car (in fact, which software bundled in the car) the device is connected to, the problem may happen or not.
When it happens, the solution is to disconnect the device from the car: then the guidance normally plays again.

Detailed explanation

After a lot of tests, I finally discovered that all works fine as long as the device is not connected to the car.
(BTW this explains why it works fine when in pedestrian mode)

A posteriori I also understood why it suddenly started to fail, when I realized that it happened after exchanging my Volvo XC60 for a Volvo V70.
The previous one was a most recent model, and it clearly appears that the bundled software is not exactly the same version.

I guess that something special in the new one (new for me, but older in time) is responsible to cause (may be indirectly) the activation of a certain configuration option (either at the device or app level).
But despite a lot of investigations I couldn't discover which one: all options I could think of seam to remain unchanged when connecting/disconnecting.
Does somebody have any idea about what might be concerned here?

So my current solution (not the ideal one, indeed) is simply to disconnect the device when I want to use Google Maps navigation.
I resign myself to not being able to use the phone during this time.

BTW if you wonder why I prefer to use Google navigation system rather than the car-bundled one, it simply comes from the obvious enormous difference at the "enter address" level: Google Maps seam to know any little locality or suburb name, as well as numerous little shops, curiosity points, and so on.
While the car-bundled navigation system (at least the ones I know) labouriously claim for town, street, number... and doesn't know anything else.

Last point: what remains totally unexplained is why, starting to fail, the guidance system was not immediately silent, but began only cutting the end of each sentence...

2
  • This additional information should be edited into the question, not posted as an answer as it doesn't answer the question.
    – Chenmunka
    Commented Jun 16, 2022 at 16:05
  • @Chenmunka: I don't understand. Why do you think it's not an answer? My question asked for an explanation about the cause of the problem and a solution to solve it: don't those two responses belong to my answer?
    – cFreed
    Commented Jun 17, 2022 at 2:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .