I am trying to root the phone, by following the instructions here. I did unlock OEM and am able to see my device. But can not flash to recovery. So I tried booting twrp first but that does not work for me either. I did see this link and the comment about using the stock boot image. I have not tried that yet since my issue is slightly different. Thanks in advance for any advice. I am doing all this on Fedora platform.

sudo ./fastboot devices
[sudo] password for ****: 
####### Motorola Fastboot Interface

sudo ./fastboot boot recovery.img
[sudo] password for *****: 
Sending 'boot.img' (42408 KB)                      OKAY [  1.581s]
Booting                                            (bootloader) Command is not support
FAILED (remote: '')
fastboot: error: Command failed
sudo ./fastboot flash /recovery recovery.img
Sending '/recovery' (42408 KB)                     OKAY [  1.676s]
Writing '/recovery'                                (bootloader) Invalid partition name /recovery
FAILED (remote: '')
fastboot: error: Command failed
  • 1
    The partition name is recovery (without slash), not /recovery.
    – Andrew T.
    Commented May 30, 2022 at 3:40
  • some devices don't have recovery partition. temporary flash twrp into boot partition instead (slot B), switch active slot, boot into twrp, Menu > Advanced > Install Recovery Ramdisk (slot A), don't forget copy slot A > slot B to restore boot.img
    – alecxs
    Commented May 30, 2022 at 9:01
  • beware the link you shared is for Qualcomm (rav). yours is MediaTek SoC (ellis)
    – alecxs
    Commented May 30, 2022 at 9:11
  • @Andrew I tried w/o slash and same result.
    – Shahin
    Commented May 30, 2022 at 14:39
  • @alecxs I tried to boot; the output is in the post. Thank you for info on Media Tek. I did not know that. If I mistyped something, please let me know?
    – Shahin
    Commented May 30, 2022 at 14:40


You must log in to answer this question.

Browse other questions tagged .